Button Events Not Working when using S2 inclusion (Inovelli Red Switch)

C7 hub and any Inovelli red switches lzw30-sn. After the newest Hubitat firmware update I tried to include a new switch using S2 and setup some scene’s via button pushes. I posted in the other C7 including issues thread about the inclusion issues (stuck on initializing) that I’m still having— I used the know workaround to get it paired. Anyways, once paired I setup the rules to handle the button push events, but no matter what, they don’t seem to trigger. I turned on logging and can see the push and held events there, but no actions. I excluded this switch, included it again without security, and added it back, as the button device, in the existing rule.... it worked fine. Tried it again, pairing with S2 and it doesn’t work.

Has anyone else experienced issues with button events, on the inovelli switches, when pairing with security?

Someone else noticed a similar problem in this thread: Button Controller Missing S2 Device Events (despite the title, it's really the device itself, and the fact that Button Controller isn't responding to the events is a byproduct of the fact that the events themselves aren't getting created).

I have one of these and have used it with S2 on a C-7 with no problems. However, this was before the 2.2.3 hub firmware and accompanying Z-Wave radio firmware update, and I have not tested it that exact environment yet. So, I'm not sure how valuable my past experience is there anymore. :slight_smile:

1 Like

Yes, sorry for the bad title. Obviously, that's a thread in which I've discovered a lot. I've been updating it as I learn, but also trying not to give anyone attempting to follow it whiplash. Hope to get an official comment on that one soon.

For anyone having this problem and not wanting to slog through my long-winded investigations, just don't use S2 and use the Inovelli drivers, for now.

This is now fixed, you should update to the latest Hubitat software and Inovelli driver versions.