Button controller only provides 2 buttons for iris 4 button fob


Adding a 4 button iris key fob. The button controller only seems to provide press and hold options for 2 buttons. Device page shows 4 buttons correctly. How to define for all 4 buttons in the button controller?

Check the device page for the key fob, make sure it has it set for 4 buttons.

Yeah, it's definitely a 4 button controller with the proper driver activated.

I get 4 options come up in the button controller: 2 for press and 2 for held. Maybe that's the issue? But there should be 8: 4 press actions and 4 held, right?

i can have 8 if I want, 2 each(press or hold) x 4 buttons

In button controller app , I just did it again and checked the prefill all buttons, it gave me 8.

Are you using button controller 3.0?

Definitely not possible here Bro. Not sure what's happening. I used the "prefill" option and selected the check boxes for pushed and held. It generated 4 options (button 1 pressed and held and button 2 pressed and held). If I try to manually add buttons with a new child instance, it just shows me 2 buttons so again I can't seem to access the other 2 buttons.

Weird. In the device it shows it's a 4 button controller although I do notice a 5th null entry in the State Variables. Not even sure what those are. Maybe I need to delete and re-add the device back in again.

The only state that is important is the numberOfButtons. In your case it shows 2 where it should be 4. I don't own this device and you aren't showing the entire device page. Is there an input that allows you to set the number of buttons manually? If so, set it to 4 and then click Save Preferences.

If you don't have an input, then try hitting the Configure button and hopefully that updates your state to the correct value. All apps use the numberOfButtons attribute to know how to present their options to you.

Nothing I can see. I was expecting the app to know its a 4 button device based on the details here at the device level...

The apps use the numberOfButtons attribute, which in your case is not setup correctly for some reason. Try hitting Configure, wait a full minute and then refresh the device page. If the numberOfButtons state doesn't say 4, then we might need @mike.maxwell on this.

Yeah, I tried refresh and configure already. I also switched out the device type to something else and then back again. I still only get 2 buttons. Strange indeed. If I press buttons 3 and 4 they are recognised and show as pressed or held in the device page.

Just an FYI. Every time you swap driver's you would need to hit configure button and refresh the browser window (after waiting a few seconds so the configure method can do it's thing).

The only other suggestion I would provide is to remove and readd the device. If it doesn't automatically get added with the right driver, take a screenshot of the detailed pairing info and provide that to @mike.maxwell.

Yes I'm aware of the need to configure. As I said, it doesn't fix it unfortunately. I'm trying to avoid remove and repair because it's used in a few flows now...but yeah will probably have to try that eventually unless there is a way to force it to recognise properly as a 4 button.

Can you post a picture of the device?

1 Like

when you initially joined this device, what driver did it select?

The correct one, this one.

I don't know how numberOfButtons got set to 2, looking at the driver code it is set to 4 when the device is first installed, there's nothing in there that would set it to 2.
The only way to reset it currently is to re join the device.
You can add a temporary virtual button device, then swap this into all your existing automations as a place holder, then swap back after deleting and rejoining the fob, that's the best I can do ATM

Ok thanks. No worries. Will try a rejoin.

Removed and repaired. Still doesn't work. Actually worse now.

In the device page I see this (it no longer stated the number of buttons)...

But again, the numbers update whenever I press or hold any of the buttons.

If I try to set up a button control, the display doesn't allow me to select properly (I guess because the interface thinks it has no buttons at all now)...

And the error in the log shows this (I guess because the button isn't set up at all so is null)....

If at first you don't succeed, reset and reset and reset and reset and reset....

1 Like

yeah, this device is difficult to get configured, there's a huge number of commands that need to be sent during configuration...
Glad you got it working

1 Like