Button Controller Not working properly

Hi all, it's been a while since I created rules for a button controller but I went to do it today and for some bizarre reason 1 out 4 buttons isn't working.

All my other buttons (all Sengled ones) are working as expected so it looks like the issue is isolated to new rules.

When I press button number 1 nothing happens 'My Bedroom - Bathroom Fan_T' which is the endpoint in question whereas it's supposed to toggle that switch - Button 4 is set to turn off 'My Bedroom - Bathroom Fan_T' which works as expected. I tried setting the same rule with with a spare remote and had the same outcome. I am also able to control 'My Bedroom - Bathroom Fan_T' via its interface.

Any ideas as to what might be happening here? My HE is running the latest firmware.

I set button 2 to toggle 'My Bedroom - Bathroom Fan_T' which works as expected - Again, this is pointing to an isolated issue with button one which isn't hardware related but driver related?

1 Like

Two things: Show a screenshot of the Event Subscriptions for the Button Rule in question, from its App Status page (gear icon). Second, instead of device logs, show a screenshot of the app's logs, for that Button Rule.

Thanks for the quick response, Bruce.

So continued on troubleshooting and managed to resolve the issue (partially anyway) - I cloned a working button, renamed it and re-assigned all the end points to the ones in question (my bathroom) so button one is now working as expected.

Now, I went to test all other buttons and noticed that the Main Bathroom one has the same issue. I went to Event Subscriptions but there is nothing there?

See below screen shot of the entire button app interface but I just can't find an option to enable loggging? Please can you advise?

The only option to enable logging is for when you create conditions which I haven't needed to.

I checked the logs again but it's only giving me the 'info' one.

You showed Event Subscriptions for Button Controller. That's not what is needed: show Event Subscriptions for the Button Rule that doesn't work. Each button-action has its own Button Rule app, and it's that we need to see.

Each Button Rule has Logging, irrespective of and unrelated to Conditions:

No, Bruce, the screen shots are from the button rule as you requested and I have already enabled logs for button one which don't seem to apply to Actions but Conditions only.

Step 1 - Clicked on the button rule in question

Step 2 - Clicked on the button 1/Pushed

Step 3 - Enabled Logging

Step 4 - Pushed button 1 on the actual remote and checked logs however there is only 'info' log rather than Triggers and Actions as per previous screen shot.

Step 8 - Checked if the endpoint was turned on as per previous step which it did not

Step 9 - Clicked on Run Actions under under Button 1/ Actions for Main Bathroom - Wall Button: button 1 pushed which indeed turned the endpoint on

Step 10 - Checked both endpoint's page and logs which confirmed it properly turned on

We are completely talking past each other here. You're posting a lot of screenshots, but not what I need to see.

Specifically, when you have the Button Rule open (Main Bathroom - Wall Button: button 1 pushed --what you show in step 3), click on the gear icon upper right corner, and show the Event Subscriptions on the page that comes up.

All of the logs you have shown have been for the device -- you have filtered for the device, so you can't see for the Button Rule. It will show app:xxx on the left, not dev:xxx. Depending on the Event Subscriptions, there might not be any logs, but I can't tell. Don't show any device logs, they aren't relevant to finding out what is going on.

1 Like

Hi Bruce, thanks for clarifying.

Unfortunately, I can't see any app logs but device logs only at this stage.

Here's the Event Subscriptions one:


OK, pushed.null is not going to work. That Button Rule needs to be removed and redone. After you redo it, see if it has an Event Subscription for pushed.1.

Not a problem - Did you mean delete the entire thing or just the rule for button 1?

I took a guess and deleted just the rule for button 1:

Created it again:

Tested but the fan did not turn on:

Ok I created a new test rule and it worked as expected - I still don't understand why the issue occurred in first place. I’d also attempted this before but had the same outcome as such the only way I got it working was via cloning an existing working rule. At least it’s all sorted now, thanks for your assistance, Bruce.

1 Like

@bravenel What causes this Event Subscriptions to get set to pushed.none even though the Button Rule shows it's connected to a button? I had to delete and re-create a Button Rule a few times to get it to finally show pushed.2

Download the Hubitat app