Button Controller not getting triggered by the button press

I put this here because Button Controller just seems to be a derivation of Rule Machine, so if it's not supposed to go here, I apologize.

@bravenel - just tagging you because the button is Lutron, but per the log, that doesn't seem to be the problem at all, the press is getting reported fine, it's that the Button Controller doesn't appear to be "subscribed" to look for the press.

I have 2 almost identical actions in button controller, 1 works fine and the other the button press isn't triggering the rule. Really has me scratching my head:

Here is the rule:

Here is the log when I press button 5 (which works):

And here is the log when I press button 4 (doesn't do anything, obviously the humidity sensor battery report has nothing to do with this):

As I said, I'm completely baffled. Any thoughts on where to even start?

Open one of the Button Rules. Look at its App Status page under Event Subscriptions. See if the button is properly subscribed.

That appears to be the problem:

The top is the working BC, the bottom is the non-working BC. Any suggested course of action?

Unless Bruce would like some diagnostic data pulled prior to any changes, I have fixed these issues by deleting the non-working action, saving rule, then going back in and recreate the action.

Yeah, pulled.null isn't going to do anything. Remove that Button Rule and recreate it.

Yep, that fixed it. Thanks for the help. There's definitely some sort of bug in there to be quashed, but at least the workaround is easy.

I have the same issue very often (I'd say 50% of the time). When i have unused button actions, I find it faster to reassign the rule to another button or action and then back. It fixes the null issue without rewriting the rule.

That being said, I agree, this is a very annoying bug...

1 Like

I've seen this off and on, and same intervention, and deleting and re-creating it resolves the problem.

I haven't tried that, IIRC, I'll give that a go next time, will be faster.