Button Controller Error and Overall System Lag

Hey All,

The other day my system started acting up - nothing that I had done that I’m aware of. I have 2 Inovelli switches that I use to arm/disarm HSM and to notify based on LED color the state of the system. I have a rule that looks for disarming of HSM and then changes the color on both switches to green. Several days again this stopped working. So I looked into my rule and saw that potentially there were some conditional issues causing the problem (though, again, it has worked flawlessly for 4 months). That seemed to fix it except it was lagging and took a bit longer than it should have on one LED (like 30 seconds or more - and today it didn’t even change).

So I opened up button controlled to look at how I have the button programmed, and I accidentally hit the “delay” toggle and ended up getting an instant error message. Now I cannot edit the button at all and the error message tells me to check the logs. I’ve taken a screen shot of the logs in the hopes that someone can help me. Thank you so much!!


PS - I just tried rebooting the hub and I still cannot access the button controller. I also realized I cannot access any of the other buttons in that particular button controller app (in other words I can edit buttons for other controllers but not for this one).

PPS - I should also add that when I use my HSM dashboard to disarm the system the light changes on the switch immediately, so I don’t think it’s a zwave issue, but I could be wrong. Using the switch to turn off HSM does, in fact, disable it. It’s not making sense to me.

Screenshot 2020-12-22 at 7.18.20 AM|337x500

Hmmm. I hit this problem once. Whatever I tried I couldn’t get to Edit anything. Had to delete and reinstall the Child button instance in the end...

Try a restore from before this incident? There are daily backups, but whenever I am messing around with a bunch of stuff I also do a manual backup so I have a restore point.

Unfortunately I don’t have a recent backup. :-(. I was able to delete the button controller and rebuild and that seems to have solved some things.

Deleting and redoing the child button definitely fixed one issue. I’m still have problems with my switches not always responding. My RM should be seeing the change in HSM state and activating colored LEDs on my Inovelli Red Series switches but it’s still quite delayed. I’m trying a zwave repair to see what happens.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.