Button controller and Zooz remotes

I have a few Zooz Zen 34 remotes around the house, and they all have worked flawlessly. If you're not familiar with them, they look like a regular Decora type smart switch, but it's actually a battery powered remote that can stick on the wall. I had always used the Rule machine for them. More recently I found the Button Controllers app. Not sure if it's quite new or I just never saw it. But, I added a new Zooz remote for something I added, and used Button Controllers, and found it was more organized than the rules. So I changed my existing Zooz remotes, and am having an issue.

On all of them, if I set one of them for a single push of either button, they work just fine. But double tap does not work. It does work when I have a rule to operate the remote, so I know the remotes are fine. Not sure if there's some setting I've missed, but I didn't have to do anything special ahead of time for single click.

Show a screenshot of your rule vs the BC setup. Are you sure on the rule you are not using "button 3 pushed" for double tapped? Since the Zooz devices support up to 5x taps when people make custom drivers they often use buttons 1-10 and do not use doubleTapped. I think the system driver supports doubleTapped events.

I would also suggest that you check the level of the two batteries in this device.
In one installation that I did, the batteries right out of the box were low...

I came across something lately with a ZEN34.
I had the advanced driver installed.
I could not programmatically change the button via a rule.
However, when I went back to the system driver, it worked.
Now, the system driver only supports double taps, unlike the advanced which supports 5x taps.
Anyway, if you're using the advanced driver, maybe changing over to the stock driver would work, especially if you're only going as far as double taps.
PS: I haven't used button controller, yet.
PPS: The debug logs might show something as well.

Below are screenshots. Yes they are set up correctly, and yes the batteries are up. As far as drivers, keep in mind these have been working fine when i was using Rule machine to run them. The only thing changed is having them work with button controller.

But, I just found something even stranger. The log screen shot is of one that double clicking turns on and off my living room floor lamps. When I changed them to Button Controllers, they were already on, and when I tried turning them off, nothing happened. I just tried it to create new log info, and they turn on, but won't turn off. So in other words, button 2 doesn't do anything when doubled tapped, but button 1 does.

Poking around further, on another remote, button 1 does nothing when double tapped but button 2 does. Just like the other, single taps work fine.

By the way, because I know I'm going to get asked. Button one turns on a light, then off, then back on. It's an LED light that has an issue where when you first turn it on, it goes to a default color temperature. You have to then turn it right back off, then on again to go to what it's set for. The on/off/on is a temporary solution until I can sort that out, but it's not a smart light.

Is button 2 doubleTapped supposed to turn those lights off? You have it set to turn them on.

Note to self. Don't work on the Hubitat when sleep deprived. It is supposed to turn them off, so that's the stuped detail I missed on that one. I still have the other one that's got one button not working. I've been over it more than once, and it's just a toggle the light, not just on or off. But, I'll triple check it later this evening when I have the chance. If that doesn't take care of it, I'll post that one and let you all find what stupid detail I missed there.


So I haven't completely lost it. Below are screen shots of the button controller and log. Double tapping button 2 works, but not button 1. And I re-assigned it to one of my smart switches to test it and no luck. According to the logs, it's detecting that the Zooz button was double tapped.

Playing around with this some more, I ended up deleting the controller for double tapping that button, then creating it again, and now it works.

1 Like

So, you like Button Controller? I have several ZEN34's but use either Simple Automation or Rule Machine. I like the ZEN34's as well. The battery seems to last a long time and it seems to give frequent enough battery strength readings. Also, I like that you can do as much as 5 button pushes. I use three in a couple places.

I prefer BC for when you have multiple button actions for a single device. Especially with the new table layout it keeps every organized.

This is 12 separate events and I can see what each one does in one screen. This would be 12 separate rules otherwise, I mean it still is 12 rules but this makes it more organized.


That is indeed very organized.

Of course, you have to remember what all the button actions do, lol.

Me yes, wife, she just usually mashes buttons until she gets what she wants.
The Off Hold I especially use, for when I get into bed only to realize the bathroom light is still on. Turns everything off except the ceiling fan.

1 Like

True... I'm always baffled when devices are marketed as "36 possible button combinations!!!" -- as if any human could possibly keep that straight, let alone any other folks in the house.

In BC, I use the notes section to remind myself of any odd-ball device-specific button maps (e.g. "4 held" really means double-clicking lower paddle), and I use the title field for each button setup to describe in plain English what the deal is. Then in the Apps page view, when you expand a particular BC setup, you get a nice summary of what's going on.

1 Like