Button Controller (5.1) Error

Hello, when I am in Button Controller 5.1 and try to add Pause/Resume Rules

I get the following error.

After this error, I can not get back in to edit the rule.

I tried the same thing and it worked for me:

Do you have other button rules - can you uninstall and re-install the button controller app?

I do have many other Button rules, but they are all 3.1.

If I uninstall and reinstall, will my other button rules be saved?

First thing - Make a backup of hour hub before this in case it doesn’t run. Have you done restores in the past? In case it doesn’t work, I don’t want you to lose your rules!

I didn’t use the previous version of Button Rules, so can’t say for sure. If they are all part of the same “Parent” app, then removing it will also remove all your current buttons, so I would not recommend removing it.

If your rules 5.1 are under a different parent app, then that app can be removed and re-installed without impacting other parent apps. Am I making sense?

Yes you are making sense, however, unfortunately, they are all under the same parent app.

Also, I just tested with ALL other menu options and the only one that throws back this error is Pause/Resume Rules.

everything else functions as expected.

1 Like

I have reported this to the support and I got a reply on the 11/11 that they will fix it with the next update.

1 Like

Ahh ok, so it's not just me then?

I hope the fix will come soon though because I have some “broken” rules now because of that I can’t use the pause/resume.

1 Like

Known bug. Fix coming in 2.3.0, now in beta.

2 Likes

What kind of rules are you referring to? Specific app name? Button Rule 5.1 rules don't have Pause/Resume.

I have buttons that pause/resume RM rules. Those rules aren’t that important so I can waite for the update. Otherwise I would have solved it by using RM for example.

I’ll look into it, but I think this is fixed in next release.

Download the Hubitat app