Button controller 5.0

C-7 | 2.2.8.136 | Button controller 5.0

Started to try a new button controller to group a set of 3 Inovelli switches (backyard lights) with a double click to turn them on/off as a group. When I choose to populate the push/held events it thew this error and got stuck on a "go to logs" screen".

Cannot explain it, but a restart of the hub fixed it. Something about the post install reboot left it in a bad state.

Just a suggestion: next time you post a problem, put the full firmware version (e.g., 2.2.8.136) and also your hub model (e.g., C-3, C-4, C-5, C-7). Things change quite a bit between each hotfix minor release as bugs are fixed, and some things behave differently on different hub models (particularly, Z-Wave issues). Without knowing EXACTLY which firmware version you are running and the hub model, it’s hard to provide help. Also, these threads persist. Someone weeks or months from now may be searching for a solution to their problem, and the solution that worked for you, on your specific firmware version, might not work for them, on their specific firmware version and hub model.

Glad your issue was resolved.

1 Like

Yeah, saw this with another user also. Not sure what's causing this... At least it clears up on reboot.

Thanks, I am a newbie to the community, appreciate the feedback. Will update the original post as well.

1 Like

Welcome to the community!

1 Like

C-7 | 2.2.8.136 | Button controller 5.0

I was trying to move ones of my rules from "Rule Machine Legacy" to "Button controller 5.0". The rule was set up to capture a double click on pushed/held across any of my Inovelli switches (about 18 of them) and turn on everything or turn off everything.

In the button controller wizard, when I start by selected all (18) button devices, it seems to fail because it constructs the "label" as a concatenation of all switch names and that exceeds 255 characters in length in the SQL (show in the logs).

app:4712021-07-17 11:22:25.091 pm errorjava.lang.IllegalArgumentException: Invalid label length, maximum size is 255 characters on line 177 (mainPage)

app:4492021-07-17 11:18:59.838 pm errororg.codehaus.groovy.runtime.InvokerInvocationException: org.h2.jdbc.JdbcSQLException: Value too long for column "LABEL VARCHAR(255) SELECTIVITY 57": "'living.switch.2, kitchen.switch.6, kitchen.switch.1, living.switch.1, backyard.light.2, formal.switch.2, kitch... (438)"; SQL statement: INSERT INTO INSTALLED_APP(VERSION, APP_TYPE_ID, LABEL, INSTALLED, PARENT_INSTALLED_APP_ID, CREATE_TIME) VALUES(1, ?, ?, ?, ?, ?) [22001-197] on line 68 (mainPage)

@bravenel Don't know if it's related. Went to create a button push to turn on a virtual switch via a PICO (#2 button) It was set for push but logs showed release. When switched to released, logs said pushed. Quite confusing. Rebooted and all was fine.

C-7 running 2.2.8.136. Create new Button Controller 5.0 for a 5 button Pico. Prefill Buttons Pushed. Select Button 1, Control Thermostats. Action - Set Thermostats. Select the thermostat and try to Adjust Heating Point. Entering +1 the underline goes red. Unable to save. Guessing the adjustment code not implemented? @bravenel

It goes red when you put in + (which is unneeded), and then not red when you add a number. Same for -. It's not broken.

I would have sworn I had tried it without the +. How does it know I want one degree warmer vs. cooler?

1 vs -1. If you put in +1, it will change it to 1. This is just the way number inputs work.

My bad. I read this

as Same for - , no need to include it. And +1 doesn't hang to 1, just throws that red underline and won't save.
Anyway, thanks again, Bruce.

What? What browser are you using? If you put in +1, and click away from the input field, it will change to 1. If you put in -1, and click away, it stays -1. In each case, typing just + or - makes the input go red until a number is typed. Clicking 'Done with this action' button saves it.

Browser is Safari Version 14.1.1 on a Mac.

So Safari, bless them for creating such a bad browser, throws the input away if you put a + in.

Chrome takes the + out and accepts the input. Firefox leaves the + and accepts the input. Only Safari throws away the input. In all three cases the number ends up without a + after you hit 'Done with this action'.

General statement: + is never needed for positive numbers. - is needed for negative numbers, but many inputs will not accept a negative number (such as dimmer level).

Yes, I tried Safari on iOS, same issue. Chrome worked as expected. At least Safari is better than Internet Explorer (imho).

C-7 | 2.2.8.136 | Button controller 5.0

@bravenel, @bcopeland, others - Can I do this with the button controller?

On all my Inovelli switches (18 of them), I would like 2x pushed/held to turn on/off everything. I would also like 3x pushed/held to open/close all my shades. Can I manage this as one button rule? Or will I need 18 rules, one for each switch separately?

This is where I am hitting a database column overflow problem I mentioned above.

Maybe shorten the names of the switches, or break it up into 2 or 3 rules?

My long dead mother is a better browser than IE

1 Like

Download the Hubitat app