Button Controller 3.1 - Error


I sent this to support but at their auto reply suggestion, I thought I would post it here as well.

Anytime I go to add a control, the moment I go to apply a button attribute it kicks me out to an "Unexpected Error" I attached the logs to the error below.

In addition on my dropdowns for "buttons" one of my GE Zwave switches is pulling up on the list as well. The driver on it is the exact same as the other 5 of the switches I have installed around the house. Not sure if they are related or totally different issues.

Any thoughts, suggestions or help would greatly be appreciated!


Ok, so you picked a button, and when you click on "Prefill actions for..." dropdown nothing happens? Or it is blank? Or is that when it kicks you out?

The error to my untrained eyes seems to suggest you didn't select an "output" device in the Prefill Actions section.

As an alternative to Button Controller, I like Advanced Button Controller community app. I find it much easier, cleaner, and nicer to use. You might want to try it and see if it is a device issue (still doesn't work) OR whether Button Controller 3.1 is giving you trouble.

1 Like

This sounds as though it's a driver issue. What driver are you using for the button device?

1 Like

I am using: Device Type = Aeon WallMote

  • deviceType: 258
  • manufacturer: 134

Is there something else you need to ID the Driver? If so where can I get that for you?

Could you post the right side of the device page, where it shows the state information.

Never mind. I see the problem. We will get that fixed for next release. In the meantime you can use the 'Button device' trigger event in Rule Machine to get the same multi-button controller interface, and this should work there.


Thank you very much!

Did the issue you just find also explain why one of my GE switches is coming up under available Buttons?

Just curious,

Some switches have the ability to be buttons too. Quite often this is in the form of double taps. So this might be (probably is) completely normal.

1 Like

Its interesting though, I bought 2 of them as part of the 2-Pack from Costco. Both are installed and controlling the exact same LED ceiling light but only one shows up that way... why would one show and the other does not?

Same driver (device type) if you go to the device's settings page?

Which model number are these?

1 Like

They are

GE Enbrighten Z-Wave Smart Switch

  • deviceType: 18770
  • manufacturer: 57

The driver that I am using is the same for all of them (there are actually 4 of them total installed in the house) and it was the one that auto populated when I added them to Hubitat.

Thanks for the help!

Which driver?

1 Like

Pardon my ignorance, but where do I find out what driver is being used?

And these are those switches that don't have the break-off tabs, and are easywire (can put line/load on either terminal)?

GE model numbers are awful.

1 Like

Yes that is correct, you can wire them either way...which was odd. but I did put Load on top for all of them and power to the bottom which is just what I'm used to doing.

Those all should be the same if they are all using the same driver etc.

If you are feeling experimental, I like these drivers:

You can install them manually by importing the code from Github, or by using Hubitat Package Manager. You would then change the driver to this one, and hit configure in the device setting page.

If you haven't tried Package Manager, it is a simple and excellent way to try new community apps and drivers, and easily maintain apps and drivers.

1 Like

Awesome Thank you very much @neonturbo I'll give them a whack. Appreciate your help!

Have a great weekend!

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.