Bulbs connect but can't be controlled

I have some sengled element color plus ZigBee bulbs that connect easily to my hubitat, but can't be controlled. Any thoughts on why they connect two easily, but I can't "talk" to them (turn on/off) through the app?

it's possible you are using the wrong driver.

1 Like

As previously stated - almost assuredly it's the wrong driver. Sengleds are funky - multiple drivers seem to ID them - but then don't work, or work correctly. Depending on model, there are legacy drivers for sengled as well as user built drivers as well. Pick a different driver - even the generic sometimes works when others don't. be sure to mash the configure, before testing.

I tried the legacy drivers, generic, RGB , etc and it still doesn't seem to work. Do I need to restart the device when I change the driver?

No. But you should press the Configure button on the device page.

Changed the driver, configured, saver etc and still nothing. When I try to turn the light off from the dashboard the light just changes from yellow to green a few times then stays yellow and never turns off.

Here are the logs

@user1184 What model bulb are they?

Now that's new technology.

1 Like

Here is the product page


Also, that status still registers that it's on, color, level etc, so it's like it just isn't accepting commands

lol corrected.

Have you tried the advanced zigbee rgbw bulb driver? (hit save then configure)

Just tried it, no luck :frowning:

Can you look at the side of the bulb and see the exact model number?


Sorry it's E1F-NSE

Yeah I'm not finding much on it....It may just be an oddball bulb that's not supported?

I know these work because I've bought them before,,, Generic or generic advanced rgbw driver.

Thanks! I actually bought the non-color version of the bulb which i have in another room, same date shipping from amazon so ill give it a shot with those! If that doesnt work ill try out the ones you sent.

1 Like

Quick update, I set the driver to Generic Zigbee RGBW light, and did a factory reset, and repaired it and associated it with the old connection. When I did this, the bulb started interacting and everything worked for about 10 seconds. Then it flashed, changed colors, and i could only dim the bulb and turn it on/off, i could no longer change color, it switched to white. Its almost like its using the hubitat settings, then overrides itself.

I'll keep messing around and post an update if i can figure out the full fix. This is the article that got me to try this. Thank you all for your help!

Since you factory reset it and it started working, now changed to the generic advanced rgbw bulb driver, click save and click configure and see if it starts to work normally