Bulb color sticking to last RGB value on DashBoard

I think I have found an issue with the color of the bulb displayed on a dashboard tile using the Color Bulb template.

Initially and before changing any of the Color Bulb Options, the color of the light bulb icon's background is white. Once a Color is picked from the "Color Bulb options" section, the background of the bulb icon changes to the selected color. The icon background remains that color even if the bulb is changed back to a Color Temperature, instead of a RGB value.

I found this initially with tiles for color bulbs and also tiles for groups of color bulbs. I was able to reproduce this with a Virtual Color Bulb. The only difference with this last test is that the Virtual Bulb starts off at a color by default, so it can apparently never go back to the white icon background.

The following screenshot shows the virtual color bulb called "Test Dashboard Tile", a Group containing the two lights to the right called "Solarium Reading Light" and the two lights contained within that group.

This test was done using Hubitat Version 2.1.8.117, Google Chrome Version 79.0.3945.130 (Official Build) (64-bit) on Windows 10 version 1903, OS Build 18362.592.

I noticed the same as well using Sengled RGBW color bulbs in the dashboard.

Also if you put two individually bulbs on it, along with a separate group that containes both bulbs, then turn the individual bulbs off the group still shows as being on even though it shouldn't.
Example:

I tested this with a set of 2 and a set of 3 bulbs and it worked correctly for me - the group shows off when the bulbs are individually turned off. I wonder if that is specific to Sengled bulbs...? I use Globe 34207 800lm RGBCCT Bulb (From Costco in Canada).

Hrm I'm not sure about Sengled bulbs. I did notice I can get both individual bulbs to show off if I turn the group off.

  • Edit tried generic zigbee RGBW driver. No difference.

I was going to see if I cand find an old OSRAM bulb of mine to test the group tiles being properly in sync with the devices in the group but I can't seem to find it them.

Anyways have you reported your original issue to support yet? The Color Bulb tile sticking to the last RGB value. I can definitely verify that one myself as I have it too. Be nice if they could at least fix that.

I only reported through this thread... Haven’t tried other avenues yet.

Cant hurt to send @bobbyD a PM. It does seem to be a bug at the very least in the dashboard.

Btw figured out the group sync issue I was experiencing. It was a setting I had overlooking in groups and scenes.

Done!

Was this ever fixed? Same issue with my first Shelly color bulb.

1 Like

Unfortunately not.

Download the Hubitat app