BUG[Fix Pending] "Zooz double switch" driver bug while double tapping button 2, debug parse and config update

@agnes.zooz will take care of you, Zooz stands by their stuff diligently.


@manuelangelrivera we'll initiate a replacement through the support ticket you have open with us.


That is the absolute truth! My first Zooz device (in fact, one of my first Z-Wave devices) was a ZEN16 MultiRelay, right after they were introduced. Apparently, there was an initial production run that had one firmware version (1.02) on the device’s underside sticker, but an earlier version (1.01) loaded on the device, and I needed a feature in the 1.02 firmware. I sent an email to Zooz support, Agnes (@agnes.zooz) apologized, and sent me the updated firmware with a link to Bryan Copeland’s (@bcopeland’s) user-contributed Hubitat driver to do the update on my C-5. Zooz has always been an example of great support. They update their firmware to add features requested by customers, and the stand behind their products 100%.


Thank you @agnes.zooz thats very kind of you. You will have my business for may years to come.


@agnes.zooz I'm also not getting any zwave responses from my switch after attempting to fix previous issues with a supplied 1.07 firmware on HE. Not usable and not sure what to do, none of my Rules fire, nothing in the logs been trying to get these things to work for weeks now. I have two of them with the same issue. Thanks

Have you tried to fallback to 1.05? 1.07 was not working for me at all. 1.05 still had the button mapping problem, but I least it was usable.

Thanks @manuelangelrivera didn't realize that 1.05 was usable. I can manage the mapping problem just needs to work etc. I find it very odd that I can't go to site and download firmware I have to email and wait for each one? Never seen that before.

Download the file with the extension .OTZ from the url given at support.
Then upload it to the firmware utility and do the flash from there. You will have to exclude and pair again once finished.

Even thou still not fixed the bug with the button pressed. I wanted to give props to the Zooz team and @agnes.zooz for going above and beyond and making sure their customers are taken care of. Thanks Agnes for such a pleasant experience with your care.


Thanks @manuelangelrivera, we try our best :sweat_smile:

Thanks as well and to @agnes.zooz. I am finally up and running on 1.05 and things are working well. Only thing is double tap doesn't work for me either in 1.05. I'll watch to see when 1.07 is ready for release and upgrade then. Cheers

That's something that got broken in one of the HE platform updates and we're hoping to see it fixed shortly.


Another small note for 1.05. A really cool feature is to be able to use the lower switch as a virtual switch and disable the native physical click to use it for something else. It's almost working but sometimes my hubitat rule that turns the light on or off that should show up as digital shows up as physical. Only sometimes though. Assume that it should never show up as physical though unless I click it with my hand so don't think I did anything wrong in HE.

My usecase is I'm able to automate both lights through the switch and then use the lower scene button to trigger my garage. Very cool to have the options to do this but sometimes opens my garage when the light turns itself off in the rule because it shows up as physical in the log etc.

Any updates on this bug?

So far, we haven't received any updates, we hope to have some news after the Holidays. Thank you for your patience!

Anyone watching this thread check out ZEN30 driver I just posted. All the button taps seem to be working fine for me in testing, although I am not using the "doubleTap" and instead sending it as button 3 for up and button 4 for down (same as ZEN27 documentation from Zooz). I could maybe make a setting to use doubleTap instead of that's the preference. I'm still working out a couple of code issues but would like some feedback on what I've got so far. All features seem to work, just not happy with some of the code yet.

1 Like

thanks for the driver...
but I'm very confused how to use the 2 switches on the Zen30 as 2 different devices.
I thought I would have to zwave connect both switches separately but that appears not to be the case. So I have the zen30 connected and using the advanced zen30 driver... but I don't see anyway to name the 2 switches with unique names (i.e recessed lights and island lights) and have 2 separate devices....is that possible?

There should be a child device under the main one. They are attached but function as two devices.

Wow as always you save the day.. Thanks !