[bug] Fade color temp over time now working

I have a hub variable with a ColorTemp Connector. When I use a rule that has worked in the past to fade the CT over time, nothing happens. In the logs I get an error java.lang.NullPointerException: Cannot invoke method minus() on null object on line 4706 (method appButtonHandler).

I am using a C-8 hub running Any help to fix this is much appreciated.

Please show us the entire rule that is causing this error. What do you mean by "variable connected to a CT bulb"?

Its a variable with a ColorTemp Connector device (Sorry I didn't have the exact name of the connection). This is the test rule I used to generate the log file with the error. I set the variable to 4000k so this rule should increase the variable but it doesn't.

And this is my old rule that historically worked.

I think I found the solution. At some point an update to raise color temp over time stopped my variable connector device from working. The device had only the colortemp state listed. This seemed to not work with the raise color temp over time. I entered a random level to the device to get a level state after testing a real device (light). The rules now work!

Makes sense. It was trying to do math on a null value.