Broadlink IR/RF remotes integration (RM3 Mini, RM Pro, RM4 Mini/Pro)

The keep-alive only works with pre-RM4 units. My RM4 reboots every few minutes, but it seems pretty innocuous.

1 Like

Ok thanks !

@tomw - thank you so much for all your work here. Truly fantastic.

I have an RF fireplace remote that is refusing to be picked up doing an RF sweep, but I can learn in the app (with direct frequency entry). Would it be possible to get the custom build to manually enter the RF frequency mentioned elsewhere in the thread?

Thanks!

This may be obvious to most people, but it wasn't to me, so I thought I would mention it. What I was trying to do with my Broadlink was control an RF/IR fan and light in my home theater, BUT only switching them ON provided too much light and too much air so I needed to send individual step commands to each so that the level for each was somewhere in the middle. It turns out I didn't need to jump into coding to accomplish this. The functionality is embedded inside the Broadlink app with SCENES. I was not only able to create single SCENE commands to accomplish what I was looking for, but Alexa also picked up the names of them. So if I say, "Alexa, turn on tornado," it runs the scene for tornado, which sends individual step commands to my fan and allowing it to spin at the perfect speed each time.

Anyway, I just thought I would mention it in case it helped someone else. This functionality wasn't immediately clear to me with these products when I got them. Thanks.

2 Likes

One of my RM4 Mini developed an issue where it would be seemingly asleep, and it would not send commands on first try, or often even on second try. Successive commands after that would work, so I was assuming that the first command (or two) was just waking it up so then it worked after. It didn't used to do this, and my other RM4 mini has not done it, so I am not sure why this behavior started. It was only when I called a sendStoredCode command from another app that it was unresponsive, if I sent a stored code from the driver page it would work every time. Maybe it just wakes up if a command is sent directly from the driver page.

The solution that fixed it was to set up a Webcore Piston (a Rule would work too) that just calls refresh() every five minutes on the driver. It solved the problem. I have not played around with how frequent the refresh actually needs to be, but five minutes worked so I left it.

Should anyone have a similar issue with the RM4s, it may be worth a try.

I'm a bit confused why you need to step the speed. Doesn't the fan have speed control where you can just send a speed level to the fan via Broadlink? Same with the light, can't you just send a level?

It also does not sound like you are using the Hubitat Broadlink remote driver in discussion here, as the Scenes set up in Broadlink App are not accessible from the Hubitat driver, or Hubitat in general. That introduces a cloud dependency when you could do this all local to your network with the driver.

You could use a Webcore piston for your Scene commands, and then call it locally. Currently you are telling an Alexa server to tell a Broadlink server to send the commands back to your locally connected device.

1 Like

Hi Tom,

Where do I look to find the code.Store in the now abandoned app, to copy IR codes to your integration and apps?

Does anyone have a problem with scrolling through this thread from the beginning locking up the chrome browser tab at about the point where post 39 appears? Chromebook, current version of chrome. Does not occur on any other long thread. Also does not occur in incognito mode. I've not previously had this experience with any other Hubitat thread, webpage or site. I'm assuming that there is something in one of the posts below 39 that I cannot see that introduces the problem. This has only happened in the last couple of days. Refreshing the page does not resolve it. I have the close the tab and start over. Not a deal breaker for me but just really curious.