Brand New Can't Find Hub

I have a brand new Hubitat, its connected to one of the three ethernet ports on my Orbi router, I can see it as a device in my Orbi app but It cannot be found through the hubitat portal. I have tried standard method and advanced using the MAC address.

The blue light is on. I have rebooted the router and hubitat, still nothing what am I missing?

Message sent to support but I was hoping I could get it figured out here first

Look in the DHCP list on the Orbi.

If it's a new hub, it's likely a C-7 (and if "new" is a bit of a stretch, then it's probably at least a C-5), which should have a green LED after the hub software gets loaded. That could be why you aren't able to see it from any normal method.

Since you've found it on your router, I'd try two things: first, try navigating directly the hub's IP address (your router should tell you that). That's really all the Portal would help you get to anyway, so you don't technically need it. But if the platform software isn't running, that's unlikely to work either. In that case, I'd recommend trying the diagnostic tool: same thing, just port 8081 (so http://YourHubIP:8081). Perhaps one of the options there (reboot, soft reset, or full reset--you'll need the MAC address to "log in," by the way, so get that handy from your router) will help you get it up and going. Otherwise, Support may certainly also have some ideas.


Thank you, yes its a new C-7. I will work on the things you said.

While you're in there, it's best practice to reserve the DHCP reservation (make it static) so your HE gets the same IP address every time.

I was able to get into the hub using the diagnostic tool. I was able to set the time, reboot, soft reset and full reset but still cannot find the hub through the portal.

If you are using Chrome as your browser, there is a known issue where it won't find hubs reliably. Try Edge or Firefox maybe.


Chrome sometimes works better in Incognito mode if you don’t have another browser..

Please see @bobbyD post here

1 Like

I am getting closer... I just tried using MS Edge and was able to find it when I typed in the IP but when I tried clicked on it said can't be reached....

If the LED on a C5/C7 hub is blue, not green, you will not be able to access the Hubitat web admin page. You will most likely need Hubitat Support to resolve the issue.


Thank you, yes it is blue. I have a ticket in but have not heard back yet

Hubitat Support should be getting up with you soon. I am tagging @bobbyD from Hubitat.


@bobbyD Can you take a look at my ticket about this? Thanks

Please check your email. I am showing that we have replied a few hours ago. But since you reached out here, you can provide the additional details in a private message, so you don't have to reply to the email, if this is more convenient to you.