Brand new C-7 Hub won't boot

Hoping someone can help point out anything else I can try, as my brand new C-7 hub doesn't seem to want to power on.

What happened:

  • Plugged in the power cable, then...
  • Plugged in the ethernet cable.
  • Got a blue light but the discover page wasn't finding it. Read that I should have plugged ethernet in first, then power. So I...
  • Unplugged the power, waited 10ish seconds and plugged it back in, and no power.

What I've tried:

  • Different micro-USB cable which I confirmed worked to power a different device.
  • Different adapter with same power output (5V/1A), again confirming it works on different device.
  • Different adapter with a higher output for amperage (5V/2.1A), again same confirmation to ensure it works on a different device.
  • Verified the Hubitat supplied cable and adapter work to power other devices.
  • Have also tried powering it on with/without the ethernet cable plugged in and have verified the router it is plugged into is not capable of PoE, so that shouldn't be the issue here.

At this point, I'm worried it's defective. I've sent in an email to support, but figured I'd post here to see if there's any other ideas or things I can try, as this community seems to be very active and helpful from what I've seen from searching for a solution.

You tried the advanced find and entered it's MAC address? I just brought a new C7 online myself. That is what I had to do to get the hub discovery to find it.

C-7 should go to green regardless of ethernet cable.



Please check your email. It sounds like your device may be defective.


I didn't, but just tried that and still no luck. I don't think that's the issue as the device literally won't power on at this point, so discovering via MAC address won't help since it's not actually online to be found.

Thanks for the suggestion though!

Just replied, thanks for the quick response!

1 Like

It's been reported that it is not a good idea to unplug the USB and plug it back in on the hub. Apparently some will break easily. Not sure if you did that but thought I would mention it if you get another one. It's been reported for awhile so maybe they have done something about it by now.

Just for clarification and future references, the hub doesn't "break" if unplugged, any more than any other computer that runs a database. If a database suddenly loses power, when it's writing data in its tables, it can get locked. If that happens, a Soft Reset will resolve the problem.


A new device is being shipped out, as it sounds like mine is faulty.

Just wanted to say I really appreciate all the suggestions, as well as the quick turnaround from the support team. Looking forward to starting my journey with Hubitat once the new device arrives, and I'm definitely encouraged by all the activity on not just my post, but this community in general.

Thanks all!


Sorry if I wasn't clear. The problem I was referring to was the hardware breaking not the software. At least that is how I understood the issue. Also I have never experienced this issue, but since someone posted it, and I have seen it reiterated several times on the forum, I always unplug at the wall and not on the hub. Maybe it is or is not a valid concern but I figure why take the chance.


Make sure your not using power adapter and internet poi.port