Bond Home Fan Wifi controller without hub add fan and light to devices in hubitat

Sorry there is so much there and not a lot of basic instructions for myself which makes it pretty difficult. The last post you helped with pictures was excellent :ok_hand: Not sure you are willing to help in that way?

1 Like

Main GitHub page for Bond integration app and drivers: GitHub - dcmeglio/hubitat-bond: BOND Home Integration for Hubitat

Apps page: hubitat-bond/apps at master · dcmeglio/hubitat-bond · GitHub

Go to the apps page and right-click on the Bond app link and copy the address:

image

Go to the Apps Code section in Hubitat:
image

Click on New App
image

Click on Import
image

Paste the Bond app URL you copied into the field:
image

Click on Import and then click on Save to save the app.

Then you go to the Drivers Code section in HE and do the same for all of the drivers on the Bond integration Drivers page: hubitat-bond/drivers at master · dcmeglio/hubitat-bond · GitHub
image

Right click, copy link, Then in Drivers Code section in HE click on New Driver, Import, paste the URL and then Import and save each driver. Just like you did for the app, but in the Drivers Code section of HE.
image

Now you have the Bond app and all the drivers installed.

Go to the Bond app on your phone. Get your Bond hub IP address and your local access token.

Click on your Bond bridge in the Bond app:
image

Tap on Network Info to get your IP, and your bond token is lower down on the screen. You’ll need to enter both of those into the Bond app you just installed on HE.
image

Go to the Bond app in the Apps section on HE, enter your Bond Bridge IP and token, and complete the steps in the app to enable control of your fans.
image

Select the fans you want to control from the Devices list and select Next, and then select Done.
image

Now go to the Devices section on your hub and you should see your fans and can now control them via HE.
image

1 Like

You are the man!!!!! I just got it setup. I was looking for a way to setup each fan with a single switch and this BOND HOME works excellent with seperate controls for fan and light. On the instructions the only issue I ran into was while using the Chrome browser I was unable to import code from website by copying URL. I was able to get around that by clicking on RAW and copying that directly into Apps and Driver code. I would like to start working on my dashboard to make it more user friendly but still another fan controller to install!!!

Interesting...yes, it's failing for me as well. I have used the import option in the past, so no idea why it's failing.

@bobbyD - any reason why Import isn't working on Chrome? I tried another github and it also fails. I swear I've used Import to installd apps/drivers previously, but maybe I am going a bit mad?

I get this warning when I try to import even when there isn't any code in the editor, and I've cleared browser cache for the past 24 hours, didn't help. Then I tried clearing cache four weeks back and I could import code once, but then it started failing again, even if I cleared the cache again...seems like Import is not playing well w/Chrome.

Glad to know it's not me haha!!!! Any suggestions you might have on Dashboard support or setup that I can start with. I currently have 42 devices...

Look up:

Smartly - amazing options but requires some config

Hubitat Dashboard app (simpler Android app option, less configurable but very nice - my wife's preferred interface)

Brilliant!

Now I only wish there were support for fans in Scenes, so I could control my fan speed from there, but there's always Rule Machine.

Hi I'm very new to hubitat. I've done all the steps to get bond connected with HE but every time I try set the app up I get an error.
I have to idea on writing code or changing code but any help would be much appreciated.

The error says
Unexpected Error
An unexpected error has occurred trying to load the app. Check Logs for more information.
Error: No signature of method: org.apache.http.conn.ConnectTimeoutException.getResponse() is applicable for argument types: () values: [] Possible solutions: getMessage()

Then when I check the logs it says
[error]://192.168.1.57/installedapp/configure/37)groovy.lang.MissingMethodException: No signature of method: org.apache.http.conn.ConnectTimeoutException.getResponse() is applicable for argument types: () values: [] Possible solutions: getMessage() on line 195 (prefListDevices)

Best if you post this here...

Thanks, will do.

So I am extremely new to Hubitat but I was with smartthings for a few years, and for some reason after i have pasted the code in for the new app it looks like it is successful, but when I go to my apps section in Hubitat I dont see the Bond integration app in the list of apps I have. Any idea what Im doing wrong? I have also installed all device drivers as well.

When you say it is not in the list, do you mean what is displayed when you first open the apps page? If so, you need to click on Add User App I think it is at the top right of the screen.

1 Like

Oh wow, thats what I needed to do. Lol i literally just got my hubitat up and running and this is my first user app ive installed. Just left smartthings and gonna give hubitat a go. thanks mate. so when i add an app with code from the community I will need to add user app everytime? Just wanna make sure so I know next time. thanks again

1 Like

Actually, forgot to mention HPM, but I'll come back to that....

I think the answer to your question is no... For apps like Bond that you typically install once, the process is essentially what you just did, load all the code and then install the app. For those apps (or drivers) where you may install multiple copies, you only need to load the code once and then install as many times as you like.

For that first part of the process, loading the code, there is a nother Community app that makes that much easier, it's called Hubitat Package Manager. I'd suggest installing that. It allows you to search for apps and drivers, install them in one click and manage automatic updates.

Hope this helps..

Simon

1 Like

Awesome I will definitely look into that. I really appreciate the help.

1 Like

No worries, think I got that slightly wrong, at least in terms of answering your question. My description is right, but the answer to your question was yes, you need to use Add User App

one more thing, the child apps are also just installed in the new app section correct? Im used to having to install the main app and publish for smartthings then add the code for child app but not publish it lol there isnt anything like that in hubitat? and im guessing the drivers section is the equivalent of device handlers?

I'm not familiar with smarttings myself, but in HE the code all needs to be loaded in the same way through the drivers / apps code or using HPM, regardless of whether it is a parent or child. When it comes to installing, you just need to install the parent using the process described above, the add user app, then any child apps or devices are handled inside the app, either by the app detecting something and creating the children automatically, like Bond detecting the devices on your bridge (not child apps I know), or by allowing the user to create them through some choices inside the app, such as adding a new rule in rule machine.

Simon

1 Like

Again I really appreciate the info. I've literally had it running for a few hours and already love it. Smartthings is ok for the beginner home automation enthusiast because it is extremely user friendly, but Hubitat seems like its light years ahead of it. I added the Lutron Integrator app with pro bridge to be able to use Pico remotes in automations, and it works amazingly well. I think I'm going to love the features of Hubitat and all the Local Control.

2 Likes

This thread is labeled " [Bond Home Fan Wifi controller without hub add fan and light to devices in hubitat]" but seems to cover using the wifi controller WITH a hub. I installed the fan and linked it to the wi-fi remote and all works. I have just a single fan, I do not have a Bond Hub. I installed the app on my phone, and it works fine, but under "settings" it does not show the fan controller address or token. Will I only be able to connect HE to the fan via a "Bond hub"? If I can do it without the hub, where do I find the IP and Token? I can scan my network and find what IP it has, but still need the token. Am I missing something?

Download the Hubitat app