Blank dashboard on Android app

Hi, I can't find any solution to this problem.
I tried to clear the cache but with no results.

1 Like

Asking the obvious here, but did you set up a dashboard? Was it working previously? Does it work on a desktop? Can you see your hub on the app (Settings, Hub in the Hubitat app)?


And perhaps one or two more....
By Android App, I assume you are referring to the official HE App? Not the community developed Android App?
Do you have a screenshot / photo of what you are seeing in the App?

1 Like

Yes. The dashboard works fine on my PC and iPad. It's only my Android phone that has issues.
It worked when I initially set it up.

Yes, the official app.
Here are screenshot:

When I push on the dashboard button I get a the HE logo spinning but not doing anything. When I try to push the dashboard button again, I get a blank screen and that's that.

Other aspects of the hub work great. I can connect to HE from the app and everything looks good.

Is the app in cloud or local mode when testing? Can you post a desktop screen shot of what the dashboard looks like?

Here's a screenshot of my desktop dashboard

not sure. It's an app :smiling_face:

The strange thing is that I tried to access the app dashboard a few hours ago and it worked! but now I tried again and the it returned to a blanked screen.

At the top right corner of the app, there is either a cloud symbol or house symbol.

Try turning your phone Wi-Fi on (you should see the house symbol in the app) and then Wi-Fi off (you should see the cloud symbol) and see if it works one way and not the other.

I don't see a house (or a cloud) anywhere. But..I do understand now that it's a wifi issue because when I turn off the wi-fi the dashboard appears.

Should see it here.

Is the phone on the same network as your hub? Or are you using something like a guest network for the phone, or did you somehow isolate your hub from the phone network?

Oh. So obviously I can't see it when the wi-fi is turned on, but when it's turned off it's on the cloud.

They are on the same network/router

One easy thing to try is to remove the phone app, reboot the phone, and reinstall the app.

You can go to the Settings tab in the phone app, scroll down to the Hub line about 5-6 items down in that list, click on that and reconnect to your hub. Doing so you won't lose anything or create any stranded devices on the hub.

You did it!
Not the app removal method but I pressed the hub option on the settings tab, reinstalled the hub and that did the trick. It's now also visible when the wifi is turned on.


Strange that I've had this same issue for the last month or so also. Was never a major issue as I normally connect via an IP address when I'm at home but I wasn't home and wanted to check the dashboard and couldn't so thought I'd look into this.

I tried the solution above by reinstalling the Hub but that didn't work for me so I had to completely uninstall the app - And then reinstall it. All working fine now but a strange error to get!