[BETA] Hubitat Package Manager

Yesterday, I noticed there were some updated packages, so I ran the updater and from what I can tell looking at the apps and drivers code, they all updated fine. But HPM is still telling me there are updates available and showing the 3 packages I downloaded yesterday as the updates. When I go to view apps and drivers, the versions showing there do appear to be the old version, even though I opened the code and verified the updated version numbers.

Instead of mucking about with it, I figured I'd post here first. Should I run a repair? Just let HPM run the updates again?

Do you have logs of when this occurred? That would help figure out what happened.

How do I get old logs to show? I go to logs, select HPM, click the show past logs button, and it does load recent log entries, but if I scroll down it doesn't quite go as far back as I need it to. If I keep trying to scroll, I see text saying "loading past logs..." but nothing ever loads.

I ran a repair on the 3 packages in question. That got HPM to stop thinking there was an update available for them.

I'm new with Hubitat and it is really frustrated due that all of the how to seems to be missing some part of the steps. Am I my missing anything about Hubitat Package Manager? I see how to use it, but I don't see where does explain how to install the Hubitat PKM to my hub.

Go to your hub and paste the app into the app code and hit save. then go to apps, user apps then add package manager.

https://raw.githubusercontent.com/dcmeglio/hubitat-packagemanager/master/apps/Package_Manager.groovy

9 Likes

https://docs.hubitat.com/index.php?title=How_to_Install_Custom_Apps

4 Likes

Thanks

I need to rewrite some of the base code of HPM to figure out why this happens sometimes. Definitely a bug somewhere. And @gopher.ny I promise to make everything asynchronous this time to improve performance :slight_smile:

2 Likes

Sending over some beer money to aid in the debugging.

2 Likes

Had another problem I noticed today. I recently picked up some Zooz Zen26s and a Zen27. I went to install @bcopeland's drivers from HPM because previously I only had the Zen21. For some reason, HPM thinks I do not have the Zen21 package installed.

So I tried running the "match up" but it said there were no matches. I went ahead and installed the Zen26/27 drivers. Went ahead and did the Zen21 as well, and now I have it in my driver's list twice.

I've only got 2 Zen21s, so I think I will just delete the previous one and make sure my 2 switches use the one managed by HPM, but I thought you might want to know about the issue.

im having an issue with theis when someone changes the name of an app.
if i update it changes in the system.. yours obviously cannot find it .. repair and update and match dont work.. etc.. only way ive found to fix it is delete package manager readd it and have it go through all my stuff again.

Actually just noticed something about the Zen21 driver. The one I installed like 20 minutes ago has disappeared out of HPM just like the first one. Doesn't show under repair, uninstall, or view apps and drivers.

Neither repair nor update rely on a name so an author changing a name should have no impact on those functions. Please provide logs and details. It's very hard to troubleshoot without even knowing what package we're talking about.

Please provide logs.

Logs of what exactly? Reinstalling the package that keeps disappearing.

More logs are better than less. So yeah, if reinstalling isn't causing the package to show up, please provide logs when you do that. Hopefully there is something that explains what's going on. I can't reproduce what you described locally so there must be other variables at play. Hoping logs will help us discover it.

It was suggested I move this post to this thread:

Tried an install of Hubigraphs twice today it goes a long way and then errors. Question I don’t see any pieces anywhere so does package manager roll back a failed install? If not how can I get what was installed removed? Hubigraphs does not show on the installed list so I can’t repair or uninstall it from package manager and there are no new devices, apps or any custom app or device code anywhere to be found. So I guess it must roll back?

Hi, as I mentioned in my PM, have you checked the logs? That is where you will find the answer of whether or not it rolled back.

Doesn't look like they go back far enough assuming I should be looking at the Package Manager App log entries.

Download the Hubitat app