[BETA] Home Connect Integration for Bosch, Siemens, Neff, Balay, Constructa, Pitsos, Profilo, Thermador and Gaggenau

I notice that quite a few other people have had the error below but I can't find a clear solution. The logs just say "Home Connect Integration Showing Authentication Page" and I can't see any way to debug further. Any help gratefully received.

image

I got our new Bosch dishwasher connected after making the change Craigde talks about however most everything shows null, I see events when I open or close the door but they are always null rather than open or closed.

The only thing I see in the log at the time is:

dev:56532024-01-23 07:09:01.096 PMwarnAmbiguous method overloading for method java.util.LinkedHashMap#putAll.

Cannot resolve which method to invoke for [null] due to overlapping prototypes between:

[interface java.util.Map]

[interface java.util.Collection]

when attempting home connect authentication, I can put in my home connect credentials and click to allow, but then I get an error. Here's what's in the logs. Any ideas how to solve it?

NVM. I read other comments in this thread with the same issue. Like them, I copied the URL out of the pop-up window when Authenticating and pasted it into a new browser window (using Edge in my case). I was able to successfully authenticate that way. Thank you for developing and giving good community support for this!

1 Like

I'm having issues with getting past the "Approve" button when connecting to "Home Connect". When I click on "Approve" I get a screen that says "Unable to connect to Home Connect. You can see the logs for more information
Close this window to try again". Below is the relevant log message. I tried deleting the app from Hubitat and "Home Connect" and re-installing multiple times with waits of over 30+ and 60+ minutes and basically have the same issue.

app:16312024-06-04 06:34:42.544 PMerrorHome Connect Integration Init state did not match our state on the callback. Ignoring the request

Each time it fails and you try again, the app ID changes so even if you’ve waited the 30 mins the callback url doesn’t match up between HE and Home Connect. Start from scratch and paste the correct url and when you get to the point where it says to wait 30 minutes or more that’s what you do - don’t click next, leave the page or anything else - wait. I had the same issue and was convinced it didn’t work but was simply not following the instructions word for word.

1 Like

I'm expecting that it's something that I missed that I will smh later. It doesn't seem to be the changing app ID, I noticed that. I believe that I'm doing the 30 minute wait at the right point. Here's what I did:

  • deleted the Home Connect app in HPM and verified that there were no "Home *" entries in the apps code or drivers code pages in HE.

  • In Home Connect, I deleted the hubitat-homeconnect-integration app.
    waited about 45 minutes

  • In HE HPM, I started the process to install Home Connect.
    followed the simple directions up to the "Home Connect Integration" HE screens

  • In the "Home Connect Introduction" HE screen, I did the following:
    -- copy/pasted the "Application ID" and "Redirect URI" from HE to HC. I'm not reusing the old one and I did see that app number increases each time in the URI.
    -- I also copy/paste the "Client ID" and "Client Secret ID" from HC to HE, because I assume those change.
    -- I waited 30+ minutes (I did not click on next yet)
    -- I clicked on "next

  • In the "Home Connect Authentication" HE Screen I clicked on "Connect to Home Connect" which opened a new window into the Home Connect screens

  • In the Home Connect screens:
    -- I entered my email and clicked on "Log in or Register"
    -- On the next screen (SingleKey ID) I entered my HC password and clicked on "Continue". I tried checking as well as unchecking the "Stay logged in" box.
    -- I waited to be redirected.
    -- I was finally on the Approve screen where it say that "hubitat-homeconnect-integration would like to". I click on "Approve"
    -- I received the message "Unable to connect to Home Connect. You can see the logs for more information Close this window to try again."

The current redirect uri looks like this except for the asterix:
https://cloud.hubitat.com/api/************/apps/1633/oauth/callback

The current HE link for "Home Connect Authentication" is:
http://192.168.86.20/installedapp/configure/1633/pageIntro/pageAuthentication?formAction=update&nextPage=pageDevices&id=1633&version=1&appTypeId=&appTypeName=&currentPage=pageAuthentication&pageBreadcrumbs=%255B%2522pageIntro%2522%255D&referrer=http%3A%2F%2F192.168.86.20%2Finstalledapp%2Fconfigure%2F1478%2FprefOptions%2FprefPkgUninstall%2FprefPkgInstall%2FprefInstallRepositorySearch%2FprefInstallChoices%2FprefInstallVerify%2FprefInstall&url=http%3A%2F%2F192.168.86.20%2Finstalledapp%2Fconfigure%2F1633%2FpageIntro

What did I miss? What's not matching? What dumb mistake am I doing?

Did you try this a few posts up?

Thanks for the quick response.

  • I modified and saved lines 761-764 (new lines) in the app code right after the HE "Installation complete" screen.
  • I waited 30+ minutes and tried again and got the new message "Your Home Connect Account is now connected to Hubitat Close this window to continue setup."

Now I have to see why I don't see "Home Connect" in the "Apps" section.

Thanks for the help. I finally got it to work. The problem was the pop up that came up after clicking on the "Connect to Home Connect" button. The trick was to copy the address in the pop up and put it into another browser and proceed with the other browser. I was using Chrome, so for the Home Connect pages I used MS Edge. Then I continued the process in Edge and closed the pop up in Chrome. After that, the App showed up in HE and I was able to select my Bosch dishwasher.

Now I'm working on a process to have the dishwasher start at 2am when I do 5 taps on my Inovelli light switch. The problem I'm running into there is forcing the SelectProgram value to "Heavy". Then the next possible hurdle is to set up a delay to 2am preferably using the timer in the dishwasher itself.

1 Like

Yep. That’s the procedure I found to work as noted in comment upstream in Jan 7.

I must say I’m a little disappointed in the functionality. I thought at least it would show me what cycle it was on. It doesn’t.

I did a little tweak to the driver code "Home Connect Dishwasher (see below for the 2 changes). I can use the "startProgram" button to start the dishwasher with a drop down list of programs/cycles. I was able to setup a WebCore pistion to control my dishwasher with the Inovelli switch and also with Google Home voice activation. The WebCore piston will turn on (audible notification) then wait until a time when electricity is cheaper to start the dishwasher.

command "startProgram", [[name: "Program", type:"ENUM", constraints: ["Heavy","Auto","Normal","Delicate","Rinse","Speed 60","Machine Care"], description: "select a program"]]

void startProgram(program) {
def programToSelect = state.foundAvailablePrograms.find { it.name == program}
if(programToSelect) {
parent.startProgram(device, programToSelect.key)
}
}

1 Like

Thanks for this advice, it saved me from pulling my hair out. It works!