(beta) Global Variable deleted - Can't delete old Rule


#1

I think I messed up and went out of order, but I've been trying to sort out how to get my heater to kick on and keep it above a certain temp when I press a Virtual Button that I'm working in the space. Other times I just keep it lower.

I think I've got the rules vetted but am still tuning a bit. One problem I have is that I tried going the global variable route and created one I could set for reference. I ended up moving away from that, and deleted the variable, but forgot to delete the rule. Now I can't get into the rule to remove it. Thoughts? Tried setting up the variable again, but no luck... :slight_smile:


#2

Click the gear icon to the left of your rule name. Scroll to the bottom of the bottom and click he red "Remove app" button.


#3

I can do that, but I don't want to remove the app. Is that just the rule or the whole rule machine?


#4

Well, I'll answer my own question. The button at the bottom you'll see after clicking the gear icon says Remove app as noted. I backed up my config and then tried it and it only removes the rule. Figured it might help someone else.

Looks to have the same functionality as "Remove" if you successfully get into the rule.


#5

Yeah, its confusing at first until you realize that Rule Machine, like many apps are a child and parent app scenario. Rule Machine is the parent app and each of the rules are child apps. So the term "Remove app" is accurate for both of them.

I suppose @bravenel might be able to change that button to "Remove child app", but I don't know if that would make sense everywhere. Much of the framework shares buttons.


#6

This change will be in the next release, to make it clear what you are removing.


Rules do get saved even without hitting the done button
Button Controller Error