August Smart Lock Pro -- z-wave (posting after reading all others)

Hi there! One week into being on Hubitat after four years of Smartthings.

It seems like a lot of folks have trouble adding their August Smart Lock Pro to their z-wave network. After reviewing most, if not all, posts, I have not yet seen a resolution.

Question is -- is there one? What does it take to get it connected?

I've been trying to pair a lock that is 8' away from my hub. Lock's firmware is updated as is HE's. When attempting to add (I put the hub in inclusion mode and then via the august app select "add to z-wave network"), Hubitat recognizes device but gets hung on 'initializing it.' Meanwhile, August app indicates the lock has been added to the network.

Many thanks in advance!

Please check the logs (past logs) to see why it hangs and what recommend next steps are.


Here is what I am getting:

sys:12022-06-21 02:47:38.899 pm Z-Wave device id: 39 failed S2 bootstrapping - KEX_FAIL_KEX_KEY: Key failure indicating that no match exists between requested/granted keys in the network. - the device needs to be excluded then included again to use securely.

Interesting -- I did previously exclude this device and received confirmation from both HE and the August app. What's more, the August app indicated that the lock was "successfully connected to the Z-Wave hub"

It was "successfully" connected, but it failed S2 bootstrapping, so the hub was unable to add it. Updated device firmware that properly handles the S2 security keys is likely what's needed to get the device added. Or rinse and repeat hoping that the device can complete the S2.


Thanks. So how do I go about updating the firmware to enable S2 security keys on the HE?

I forgot to mention that when attempting to pair, I receive an error message from the August app that states the following: "You are connected to a z-wave hub that is using the S0 security protocol. August Smart Lock Pro supports the newer S2 protocol, which we recommend for the highest security".


Which model of Hubitat hub are you using? The current model, the C-7, already supports S2. Older models: the C3, C4, and C5 do not.

1 Like

If this is a C7 hub, does Hubitat prompt you to enter or verify a security key? (It should).

Being that it is a S2 device, does it have the Zwave Smartstart QR code? Did you try including it that way?

1 Like

The firmware update is needed on the August side, not Hubitat. Your hub can already handle S2.


Thanks. Pretty strange. I do have a C7.

My lock does not have a QR code, but does have a zwave plus five digit code, which I have entered when selecting the option to include with Security.

@bobbyD Why do you think the August app is giving me that error message saying the hub is running S0 and that August Lock Pro already runs S2?

I did look at the August firmware, and saw one of the locks is running an older version. Unable to manually trigger the update, so will ping August support to get that lock updated and ensure all of them are on the latest version.

1 Like

You may want to search the community for "failed S2 bootstrapping" to see how other manufacturers handled this issue.

1 Like

Because the hub is unable to include with S2, so it tries the next "best" thing, the S0.


The solution is to use a different lock altogether.
Over two years I was trying to get it working on the ZWave network.
No matter what I tried it didn't work reliably.
Further more, when it is connected to the ZWave it eats batteries within
3 weeks but the communication is near dead.
Finally I ordered U-Lock Zwave lock. It should arrive shortly.
I was thinking about Zigbee version but finally chose ZWave U-Lock.

1 Like

Let me know what you think about the U-Lock!

I did get the locks (I have five of them) working within HE, just not with z-wave. For time being, just pleased to be able to control them.

I appreciate all of you trying to help!

U-Lock ZWave (keyed version) came in yesterday (06/24) and immediately replaced my
August Pro. The replacement and setup took about half an hour. I used the U-Lock app.
for the initial setup and configuration.

The HE does not have the U-Lock specific driver. It uses "Generic ZWave Lock" driver.
As of now only Lock/Unlock commands are working. I am OK with this because that is
it what I need for my Front Door automation. Driver has some other capabilities
but they are not functional.

Unlike August Pro, the U-Lock response for the ZWave commands is very fast and
so far is very stable. Finally my "Front Door Automation" became 100% functional,
very fast and so far reliable (I hope this is a case).

1 Like

I am glad to read you've found a suitable replacement. I am still upset with myself for spending so much time and effort trying to get the Augusts to function as intended. My Z-wave DanaLocks have worked perfectly for almost nine months now.

I was able to talk another customer at Home Depot out of purchasing an August or Yale, so I got a little satisfaction. :grin:

I was thinking about DanaLock but Zigbee version.
My setup requires (historically, kind of) a Keypad and a WiFi Bridge.
This was a bit expensive if I chose a DanaLock.
I got the U-Bolt Zwave with plus WiFi Bridge (keypad is a part of lock)
for only $180 (surprisingly I got a sizable discount at checkout).

For the August Lock Pro - I was very happy with this lock as a stand alone.
But ZWave never ever worked for me regardless of all my attempts to get
it working. I had reliable integration with HE but cloud-based (foo) and RPI
with Home Assistant. This actually worked but the response was very slow.
So far my door automation with U-Bolt ZWave is flying.
In addition to locking/unlocking the lock I have an electronic Door Opener
installed and two BLE Beacons as "Arrival Sensors". Now front door is 100%
And finally my front door automation got a 5 stars for WAF.
(With the August Lock Pro all what I heard - was a lot of barking.)

1 Like

Curious as to why you included Yale in that - there are community members here who swear by Yale w/Z-Wave module..

As an aside I do prefer and use the Yale w/Zigbee module myself and tend to recommend Zigbee for locks in general. Yale for me as a product has been working great for 2+ years or so now.

Honestly, I haven't used a Yale product. At the time, I was really upset with what August had become after becoming part of Assa Abloy (Yale's parent company too). When they started sharing the same app and the same ineffective customer support, I decided that was a brand I wouldn't ever consider.

It is just a personal revenge thing against Assa Abloy for crippling a perfectly good product. I bought a z-wave lock for a reason. Don't tell me to move the lock to Wi-Fi if I want it to work reliably!


Oh man I certainly understand that reasoning.. just wanted to mention the Yale assure stuff seems to work okay in case someone already got one and was worried. Note: I have a YRD256 with Zigbee.