Attempting to Integrate HomeKit with Hubitat

I've added my Honeywell T6 Z-Wave to Hubitat. Now I'm trying to integrate it into Apple HomeKit but I'm getting the error "Uncertified Accessory" and "Unable to Add Accessory".

Surely there is a way to add my thermostat to the Home app. Has anyone had experience with this?

that isn't an error, it's informative. Apple won't help you with uncertified accessories. But this community will. :smiley: My advice, ignore it. Hubitat is working to get certification, and therefore the HomeKit Integration is waiting on Apple to do their part.


Is the issue to be resolved and the communication into Homekit is where I'd begin, assuming this is your first try using the Integration. Do you have VLANs? mDNS is needed and most VLANs kill that unless corrective efforts are made.

I have 5 Hubitat hubs using the integration as I glacially shift from HomeBridge to Hubitat Homekit Integration. I've encountered that message many times and I was just persistent.

1 Like

Hi there, thank you for the reply. No VLANs.

We just moved into a new home that has a z-wave thermostat and light switch which started this endeavor. I tried the Aeotec Hub initially but found the integration to HomeKit to be frustrating. After reading about other people success with Hubitat I made the switch.

I only own a MacBook so I'm running on MacOS. My goal is to have any smart devices controlled though Apple HomeKit but I'm worried about how to accomplish this. Lack of knowledge on how to get around the "Uncertified Accessory" message.

If you have any suggestions on how I could move forward I'd be very grateful.

You don't mention much about your environment, which also makes me wonder, perhaps you didn't read the documentation that is available:

It's not much but then again, Homekit Integration isn't difficult either. If you got as far as "Unable to Add Accessory" you probably have accomplished 99% of what the documentation offers.

I guess first, how far have you gotten? You mention a light switch, did you get that to show in Apple's Home App?

I hadn't read that exact documentation but was able to find a similar walk-through online. And yes, you are correct, I've basically followed the steps to integrate but just hitting a wall at the last step when I get the "Unable to Add" message, and I do not see the devices showing in the Home App.

I've tried the thermostat by itself, and the light switch switch by itself. Same message, same results. I'm still unable to get the devices to appear in the Home App.

It's a Honeywell T6 Z-wave Thermostat and a GE Dimmer light switch btw if that's helpful.

I believe you have to have an always on Homepod or AppleTV in order for Homekit to connect to anything.

Apologies. To clarify, my only computer is a MacBook, I've got a 4K AppleTV I'm trying to use as my main hub.

I've got a Honeywell T-6. Homekit sees it. You do have to enable it in the Hubitat Homekit integration app.

1 Like


So I started walking through the steps to take screenshots of what I was seeing, but now it seems to be working.

I have no idea what changed. I did reboot my AppleTV since I tried last, and maybe that helped.

Anyways, hooray.

1 Like

For now it seems I'm good. I rebooted my AppleTV and the devices are now showing in the Apple Home app.

Thank you for your time today!

1 Like

I think time is one element... I noticed that a minute or more was needed before a hub appeared.

And yes, rebooting the Apple TV Hub never hurts when you're tracking down a problem.


1 Like