Arm Home not working on Ring Keypad Gen2

I just opened a new Ring Keypad Gen2. I managed to get it paired and configured HSM to use the keypad. I am using the HE official driver with the Gen2 keypad.

When I enter my pin, and press the arm button (Arm Away), it goes through the arming phase, and then HSM is armed in away mode.

If I move my hand in front of the keypad, the away mode button lights up red.

When I enter my pin, and press the partial arm button (Arm Home), there is no indication anything happened. HSM arms the system in home mode, but that is all that happens. The partial button (arm home) does not light up, instead the keypad continues to signify that the unit is either disarmed, or armed away (whatever the last state was).

At any point, I can disarm, and the action is as expected.

What is interesting, is that if I go to the keypad device and arm home, then wait for the HSM to enter into Armed Home mode, then I arm it again for home, then it will enter the keypad will enter the home and armed mode.

If I try to arm home before HSM enters Armed Home mode, then nothing happens on the keypad.

Is this a known issue?

I just discovered that if I set the "Delay arming Armed-Home by this many seconds" option to "0" then the partial arm works as Arm-Home, and the LED get lit correctly.

Has anyone documented how to integrate the Ring Keypads with HSM?

Not a known issue.. I’ll check it out.. Thanks for reporting the issue

1 Like

Now that it is working with that one setting set to zero, I love it. I few things I would like to see add some time, but this is the solution I have been waiting for to implement any smart home hub as a security device. Thank you for integrating the device.

I’m all ears :ear:

Didn't want to take this thread off-topic.

I noticed the emergency buttons do send events. Being able to capture police, fire, and medical as child buttons would be nice.

Also, the ability to arm w/o a pin would be great too. I can see that in the debug logs, all these events are sent. For my use case, having to enter the pin to arm is acceptable, just not desired.

And finally, in HSM, having an option to clear an alert when disarmed from keypad would be great. I could see this being a feature where we press disarm, while being disarmed, could also achieve the same clear alert option.

I am new to HSM, so maybe I am missing something. HSM is something I have played with, but could never implement since I didn't have a keypad to control, and because geo-fencing was not acceptable in my situation.

1 Like

Yea.. Didn’t know what to do with this.. No real capabilities setup for this.

Ok.. I can see that

:thinking:

Could be nice to just trigger generic button push events for them. Maybe could use them to run some other automation. Maybe use one as a sort of panic button or something...

1 Like

My logic was, if HSM is in disarm state, and alerts are pending, then clear alerts when disarm button pressed w/o pin. I make my lights turn red on color bulbs, and z-wave switches that support flashing, to flash. When I come home and disarm the system, I have to manually launch HSM to clear the alerts and restore my lights back to normal. Now that I have a sharptools wall panel, it is easier, but this would be optimal.

As @djw1191 mentioned, and this is really what I was thinking, it would be nice to be able to trigger rules by treating these as buttons.

I am also having the same issue. Setting keypad to away works as expected but setting to home, while setting hsm correctly, does not reflect on the panel. Setting home delay to 0 had no effect

1 Like

Same for me - away works but home and night don’t reflect on the ring panel

I'm having an issue with the Ring keypad and if any of you folks can provide guidance that would be great.

  • I have a Ring V2 keypad (new)
  • I do not have a Ring hub. I paired it directly with the Hubitat C7
  • After many tries and resets I got a successful pair and included it in HSM
  • I put in codes, code length, delays, etc.
  • When I press configure on the driver they keypad announces the current status of HSM and when HSM changes modes the keypad reliably announces the mode changes.
  • However, the communication indicator is red (which indicated network comms problem) and the keypad will not control HSM. I can enter my code and press, home, away, night....doesn't matter. Nothing happens.
  • searched the ring documentation and they recommend a reset (not full factory reset), so I've done that and resent all the code data etc. via Hubitat. It continues to work as described above but I still can't change any of the modes from the keypad.
  • I did get the security page on the login and was able to find and enter the 5 digit code they ask for when I pair.
  • I believe I have a good pairing. I'm pretty sure my z-wave is strong enough (plenty of devices nearby), but no luck.
  • curious if there's a secret step I'm missing.

Sorry for the long post, but if anyone has a clue I'd appreciate it.

How far is the keypad from the C7 hub. Make sure you are close to the hub when you pair it. I sit right next to mine, because the security stuff can be picky. Only after you get everything working would I try moving it to its final resting spot. Most all of my Seaver stuff is z-wave plus, so the security stuff communicates just fine over my other switches and dimmers. Security is off in may of my devices. A couple items have S0, and I even have on dimmer that paired S2 unauthenticated, but the ring is linked direct to my C7 hub, even though other devices that are closer to the hub are routing off other devices. So if you pair direct to you hub while just a few feet away, I suspect you may find it works better.

The first time I tried pairing, I had issues too, And I paired it near it final living spot, so I moved near the hub and it worked. This is just a guess, but I assume you may be doing the same.

Hello Armand, thank you for the reply. I did get a chance to try your suggestion and it definitely helped with pairing. I was able to get the keypad to join the network more quickly and reliably. Unfortunately, it didn't solve the problem fo the keypad not controlling HSM. I found that if I changed the security settings to S0 when joining, the red light (indicating comm problems) did not come on, but the keypad still didn't function. I've got a ticket open with support and am waiting to see if they have any suggestions. At this point, I think there is either something that isn't getting initialized, a problem with the driver or maybe with the keypad.

I had mistyped the code, and paid S0 as well without any luck. I factory reset the keypad, and paired it S2 authenticated, then I defined my two pin codes, and issued a configure command, followed by a refresh. after which I was able to issue mode changes on the keypad using the pin. I am using the built-in Ring keypad driver (not one of the few 3rd party drivers). Then in HSM I was able to select the Ring Keypad under then "configure arming/disarming..." options section. save the settings, and it worked. If re-pairing double check that you added the correctly paired keypad to HSM.

Yeah, Ring equipment is a little particular about how they are paired.

Another thing that comes to mind is how you are using the keypad. I was doing it wrong at first, maybe you are too? the process is you enter the pin, then press the mode to active. I was pressing the mode, then entering the pin, and pressing the check mark to accept, which is similar to how some security system I used in the past worked. But this does not use the check mark with Hubitat. I think that is for when you are registering the pin codes at the keypad directly.

Thank you for the follow-up on this. I tried to follow the sequence you described above precisely, but didn't follow how to do "refresh". I didn't see a button for that on the driver page. Am I looking in the right place? I do get so far as seeing the keypad in HSM and am able to add it. The keypad even responds to changes in HSM status with the appropriate lights and voice confirmations. It just won't do anything when I try to control HSM from the keypad. I do enter the code then the action (Arm Home, Arm Away, etc.)

It sounds like in the HSM app you have not added the keypad.

Hi Armand, thanks for your time investment here. I think I've got it added correctly as I did this on an IRIS keypad and it worked. Let me know if this looks correct to you.

Download the Hubitat app