Aqara Smart Plug SP-EUC01

Trying to get a Aqara Smart Plug SP-EUC01 to work. I can get it to as a switch with a few different drivers, but the power reporting doesn't seem to work whit whatever driver I try.

Does anyone have any tips or ideas?

I've seen people reporting mixed success with Aqara gear... this post looks like a different model but perhaps it may offer some value?

Thanks for posting. I tried that driver but it doesn’t report power either. But you got me on the case again and I’ve noticed the generic Generic ZigBee Outlet and that one works.

I am using the Zigbee - Xiaomi/Aqara plug/outlet driver by Oh-La Labs with the Xiaomi square version, and it does report power and work flawlessly.

I use it to monitor my garden pump in combination with my watering system.

I tried that driver but it dosnt report power with the round Aqara plug SP-EUC01. At least not when I tried it. I have posted on their forum about it.

Did you ever find a solution, I am having the same issue

Yes, I’m using the Generic ZigBee Outlet.

Tried that, no luck
I will give it another try, thank you for the answer

1 Like

It is working, again thanks a lot. Now I get a notification when my espresso machine is ready :smiley:

1 Like

No luck here - after initial pairing it reports as Xiaomi/Aqara Motion Sensor. I've changed driver to Generic Zigbee Outlet but still cant control or event cant get device details.

Have you pushed Configure after you changed driver?

Yes- I've pushed configure, tried to refresh etc. Will upload log later on

Hej Henrik.

Did you get that particular smart plug to report power with the "Generic Zigbee Outlet" driver?

And did you try to make a graph to monitor power usage?


Yes I did, and never made a graph.
Did I read something about hobigraph? Think so.

Hi Henrik

I have been using HubiGraph for quite some time and I love it. A lot of configurable ways to present data. If possible I would even support the author.


is the plug still working for you? I also have a Aqara plug, however mine is not working with the driver. Which driver are you currently using?

Thank you :slight_smile:


I also tried to use Generic Zigbee Outlet, pressed Configure, but nothing happens.

When i try to add the driver code and hit "save" i get an error message

unexpected token: * @ line 2, column 2.

You need to remove first "/" from 1st line