Apparent networking issues

You can always ask @support or @bobbyD for their opinion. As for not ready for prime time, pretty sure most on here will disagree.


Thanks for tagging them. Hopefully they can help.

Most devices use DNS as their internet check - e.g. if they can resolve a given hostname.

Agree that the static IP may be related to your issue - often DNS server information is provided to a device with the DHCP lease, and without that, the device either must use statically provisioned DNS servers, or assume that the gateway (router) provides DNS

Yes. As I said, I've tried specifying various different DNS services in the static IP configuration with no success.

My apologies, missed that in reading your original post.

Can you provide details on your router model, configured DHCP range and static IP assignment? Perhaps your router is enforcing firewall rules on IPs outside of its DHCP range?

1 Like

I would check this thread for ideas on troubleshooting cloud connectivity issues:

I did check that thread before posting. In that thread, it sounds like there was a much more complex network topology. In my case, I have no VLANs, everything is on the same subnet, and everything has access to the internet.

Well, I switched to DHCP and it's working now. Sounds like this device just doesn't handle DNS correctly with a static IP configuration. Sounds like the devs should either fix that feature or remove it.

Glad to hear you got it working, even if not in your original desired configuration!

Just adding a few more details -- yes, for smart home stuff, a "static" IP is recommended

  • This could be static IP configuration on the device, as Hubitat allows. Your router has to support such devices on the network, including allowing access through its firewall
  • Or use a DHCP reservation in your router, so that it is always _assigned_the same IP, achieving the same end goal.

You can change* the default DNS in settings if the provided one doesn't work for you (Settings >> Network Setup).

*min hub version 2.3.1

I've used static IPs with several clients and they have been working fine just as a counterpoint. I have not experienced your issue.. :crossed_fingers: but typically I reserve an IP address on the router using the hubs MAC and let the hub do it's default thing.


Yes, that's exactly what I did. It didn't matter what DNS server address I configured. It couldn't resolve anything unless I switched back from static to DHCP.

@erktrek, that's a DHCP reservation and not a static IP. A DHCP reservation is what I ended up having to do to make it work, because a static IP configuration appears to result in failed DNS.

1 Like

Have you tried CloudFlare?

Yes. was the second one I tried.

Odd, we will have our platform engineer look into it to make sure it works as expected. Thanks for your feedback.


Gotcha and that's probably the best way to do it in my experience. However as I've said I've done it the other way via static IP and have had no issues - using client's ISP routers usually but one was an EERO set as bridged.

Are you sure your DHCP range was not colliding with your static stuff? Also (and you probably know this, so apologies) you are not inadvertently in a double-NAT situation. Also check your router config, sometimes DNS is wonky there too.. lots of possibilities.

For my home system I run OpnSense with Ubiquiti underneath (CloudKey Gen2 / POE switches / WiFi 6 aps etc).


It seem like this has been solved for now, but in the event you want to try to convert back to static or someone else comes upon this thread, I would recommend including a screenshot of the hubโ€™s network settings next time.

Perhaps it was something as simple as a typo that others may pick up. Maybe you use a subnet that is larger than a /24 (the hub is statically set to use a /24 for example). All that to say, the static IP settings do work for others, so whatever the issue was it had to have been unique to your setup.

Good luck!


No typos, /24 subnet.


Strange, set that up and didn't have any problems myself. (I usually use a reservation for convenience though) Hmm... is .65 within your dhcp pool or outside of it?

Note: I use a watchguard t35 firewall which handles my DHCP and allows everything outbound. I mention this only to differentiate how my network is set up vs yours

1 Like