Apparent networking issues

I'm really trying to like this device but for now the bugs seem to outnumber the features. Hopefully I can get some help getting it working before my Amazon return window closes at the end of May.

As far as I can tell, most (if not all) of the issues I'm seeing appear to be related to the HE's networking (and specifically DNS). The symptoms are:

  • I have a system message that "cloud connection is unavailable"
  • If I go to Settings->Check For Updates, I get the "Checking For Update" screen which animates forever and nothing happens. I don't see anything in the log relating to this operation
  • If I try to use the Hubitat Package Manager app, it fails because it can't resolve raw.githubusercontent.com

I assigned my HE a static IP in the network settings. Nothing else on my network has any issues resolving raw.githubusercontent.com or accessing the internet in any way.

I've tried rebooting the HE multiple times and tried different DNS servers.

I've also searched the forums for all of these problems and found a few people with these issues but no sign of any solutions.

Any help would be appreciated.

Cloud connection unavailable says that the hub can’t get out to the internet, the other issues are a result of that fact. Personally I’d reset the network settings using the small reset button hidden in the bottom of the hub and see if that restores your ability to reach the internet.

5 Likes

What does that reset them to? DHCP?

And why wouldn't it be working with the current configuration?

back to DHCP - correct

Some routers don’t seem to like the static setting, not sure why.

1 Like

I appreciate the suggestion, but if trying random things is the way to get this thing to work properly (maybe), it's probably not quite ready for prime time and I should look for a different device.

You can always ask @support-agent or @bobbyD for their opinion. As for not ready for prime time, pretty sure most on here will disagree.

2 Likes

Thanks for tagging them. Hopefully they can help.

Most devices use DNS as their internet check - e.g. if they can resolve a given hostname.

Agree that the static IP may be related to your issue - often DNS server information is provided to a device with the DHCP lease, and without that, the device either must use statically provisioned DNS servers, or assume that the gateway (router) provides DNS

Yes. As I said, I've tried specifying various different DNS services in the static IP configuration with no success.

My apologies, missed that in reading your original post.

Can you provide details on your router model, configured DHCP range and static IP assignment? Perhaps your router is enforcing firewall rules on IPs outside of its DHCP range?

1 Like

I would check this thread for ideas on troubleshooting cloud connectivity issues:

I did check that thread before posting. In that thread, it sounds like there was a much more complex network topology. In my case, I have no VLANs, everything is on the same subnet, and everything has access to the internet.

Well, I switched to DHCP and it's working now. Sounds like this device just doesn't handle DNS correctly with a static IP configuration. Sounds like the devs should either fix that feature or remove it.

Glad to hear you got it working, even if not in your original desired configuration!

Just adding a few more details -- yes, for smart home stuff, a "static" IP is recommended

  • This could be static IP configuration on the device, as Hubitat allows. Your router has to support such devices on the network, including allowing access through its firewall
  • Or use a DHCP reservation in your router, so that it is always _assigned_the same IP, achieving the same end goal.

You can change* the default DNS in settings if the provided one doesn't work for you (Settings >> Network Setup).

*min hub version 2.3.1

I've used static IPs with several clients and they have been working fine just as a counterpoint. I have not experienced your issue.. :crossed_fingers: but typically I reserve an IP address on the router using the hubs MAC and let the hub do it's default thing.

3 Likes

Yes, that's exactly what I did. It didn't matter what DNS server address I configured. It couldn't resolve anything unless I switched back from static to DHCP.

@erktrek, that's a DHCP reservation and not a static IP. A DHCP reservation is what I ended up having to do to make it work, because a static IP configuration appears to result in failed DNS.

1 Like

Have you tried CloudFlare?

Download the Hubitat app