App not triggering on virtual device change

Hi, I have a C7 running but this was also happening on
I have an app that modifies the color on the LED strip on my Inovelli switches if the garage door is open after sunset. The app has several triggers, at sunset it turns the LED strips "on" to warn me if the garage door is open. It is supposed to trigger when the garage door open/close status (a virtual contact sensor) changes, and would then turn the LED strips "off". This has worked for over a year. Recently I noticed that the LED strips were not turning "off", and the logs seem to indicate that the app is not triggering.

I have shutdown my hub, pulled the power, and rebooted, it hasn't helped.

Any suggestions on what I can try?

I don’t see enough on the logs to tell what’s going on… or maybe I’m just too tired and need to go to bed now… :stuck_out_tongue_winking_eye:

Have you considered using the LED Mini-Dashboard to do this?

1 Like

Thanks Sebastien. I didn't know about that option, and may look into it.

However, the actions in the app works fine, if triggered. If I open the app, and manually run the actions, the LED strips turn "off" as they should. In the logs, it's really the top entry that's important, I believe. I have it filtered to show only the entries from the app in question. That entry should have triggered the app, and it didn't.
So the app has 4 triggers, and the trigger at sunset + 1 minute is working (it turned the LED strips "on"), but the trigger for the virtual contact sensor change is not triggering the app.

I'd start looking at this sensor then. Can you navigate to its device detail page, go to "Events," and the shared a screenshot of at least the last few entries? (Or, less fun, I can tell you up front what I'd look for. :joy:)

1 Like

Here's the screen shot of the events for the virtual contact sensor. The app that is not being triggered is Inovelli Notifications Garage.

Well, there goes my idea that something strange was happening like the sensor trying to send two "closed" events in a row. :slight_smile: I don't see anything wrong there.

Two things I'd try: either just open this rule and hit "Done" to re-initialize things, or try re-creating it in case something got corrupted during previous edits/changes that may not be apparent from the UI. Also, if you aren't on the latest platform release (try Settings > Check for Updates), I'd suggest running that as well -- I can't recall any specific fixes, but at least you're not troubleshooting something that might no longer exist.

+1 this topic - I recently added an RGBW strip light - and playing around in RL it goes on as commanded but not off. In my config I use two flavors of it - one CT, one rgb. The CT one tends to not go off. I haven't troubled about it but now that you've pointed it out I may have a look closer myself.

Thanks. I am on the latest platform release, and had previously tried the open app, click Done routine. I think I'm going to try deleting that trigger and then re-adding it.