App fails since FW upgrade. Outdated Thermostat Driver

Just upgraded to and now one of my "basic rules" fails with this message:
[app:238]( 16:40:09.152[error]( Lexing failed on line: 1, column: 2, while reading 'o', no possible valid JSON value or punctuation could be recognized. on line 1177 (method mainPage)
It simply set a TRV thermostat setpoint to a level at a set time of day, every day.

follow up-

since that update (above) i can no longer create the rule that crashes as the creating of the rule causes an error.
can someone else try this please-
create basic rule: at set time of day, control thermostat to set setpoint to X.
this crashes the app

Your thermostat driver is out of date, and needs repair. You can repair the individual thermostat device fairly easily. Show it's Current States with a screenshot, from its device page.

thanks for the super fast response. the driver is a user-developed one
Screenshot 2022-11-27 170040

i tried replacing with the built-in generic z-wave thermostat driver but get the same issues whether trying to edit the "broken" app or create a new instance.

how do i fix this?

You have to temporarily change the driver for this thermostat to Virtual Thermostat (the pulldown for Type). After selecting Virtual Thermostat hit Save Device.

Once you do that you need to put this into setSupportedThermostatModes command, and hit that button:


Then put this into setSupportedThermostatFanModes command, and hit that button:


Then you will see the settings under Current State for supportedThermostatFanModes and supportedThermostatModes showing the words in quotes, unlike what they show now.

Then, change the driver back to your current driver, and hit Save Device.

thanks again for your fast response and help.
Done as instructed and it appears to have fixed the issue.

for future reference, is this a side-effect of the FW upgrade?

for anyone else reading, the bracket part must be included

many thanks @bravenel

Follow up to this problem.
i havent upgraded since applying this "fix" and the issue has re-appeared.
when i followed the procedure, the available modes were already there (see screenshot)

redoing the (above) suggested fix again appears to have solved the issue for now.
Will this be something i need to do as regular maintenance?

This is out of date. See this post: