Anyone Using Hubitat Connected via WiFi?

I'm curious if anyone has any experience with using HE over WiFi on a device like this:

I wouldn't think HE would require a ton of speed...but I wonder how much the performance would suffer.

Haven't done that.

But for ~2.5 years, I had a Wink Hub 2 connected via ethernet to an old router (802.11n - so restricted to 300 mbps) running dd-wrt in repeater-bridge mode. And had a Lutron Smart Bridge connected to the same repeater-bridge before that.

1 Like

I don't believe the HE hub requires speed. It's more about processing power and the radios. You aren't really running anything over ethernet or wifi that requires a ton of speed or bandwidth. The device you posted is only 802.11n, on 2.4GHz, with a max speed of 300Mbps and should be sufficient to run an HE hub.


Pretty much any WiFi client bridge device should work just fine. I can’t speak specifically to the one you posted though. But yeah, any 802.11n device should be more than fast enough.

1 Like

Well, that is good to know. I might just have to go this route, then. :+1:t2:

1 Like

I'm still currently on my Wink Hub's becoming a little unstable so I have decided to move over to the Hubitat. It has been fine for the most part, but I'm outgrowing it a little and looking to get more local control. The wink hub is connected over WiFi and I haven't had any issues using it that way. Just wanting to see if there was anyone else in a similar boat. :smiley:

1 Like

When pairing my Schlage z-wave locks I had to move my hub so it was just 6” away from the lock. I used an old Apple Airport Express and set it to join my network. Then plugged the Hubitat into the airport. It worked great and I didn’t notice any latency vs when the Hubitat is plugged directly into my primary router.

Just another anecdote that using any old Wi-Fi repeater hub should work just fine.

1 Like

Thank you.. Hub and the IOGear WiFi device will be here sometime today. :+1:t2:

1 Like

I know it’s not the same, exactly, but I had one of my Hubs set up over a Wi-Fi bridge. Worked great :slight_smile: Latency is a little higher, but it’s completely functional. My preference was to have one less moving part, though, and I ended up routing it in the end.

When I need to add a z-wave device that requires close pairing, I’ll power down my hub, plug it into a Wi-Fi bridge like you listed, and walk over to the device. That works very well, too.

Hey welcome to the community. There are so many kind and very talented people here, it's quite amazing.
Enjoy your Hubitat.


Just checking back in.. got the HE installed with the IOGear dongle listed above. Of course I have no frame of reference to compare it to hardwired, but I'm happy with the response time. :+1:t2:


Anyone having any luck with the new Networking using WIFI in the latest update I trying but getting the following error "ERR_CONNECTION_TIMED_OUT" I got the TP-Link AC600 Dual Band USB Adapter and the cable for power and USB? I can see the static IP and the hub shown up when I clicked on find my hub and went I try to open hub I get the error? Apparently I'm overlooking something. Thanks also when I use a ethernet cable the hub shows up and is accessible.

Ugh...this is why I never update mine. I use wifi...but i'm still on It works with all my devices and I never have to do anything to it...just reboot every couple months. I'm in the if it ain't broke, don't fix it camp. I hope you can find a fix though. :crossed_fingers:

I'm just starting. But was suppressed that I plunged the HE in to my Ubiquity AP & even moved it to a second one and it worked with out any thing.

New to the community and trying to configure a TP-Link AC600 and cannot get the HE to recognize or connect via WiFi. Has anyone done this successfully and can you offer some step by step directions?

I use a BrosTrend AC1200 to a 8 port switch then the Hubitat connected to the switch, works great. Also for my OTA TV and AppleTV.

Welcome to the Hubitat forums!

I haven't done this, but...

Can you describe what you did? Did you for example install the driver in the Settings tab, Network menu?

Did you install the driver before plugging in the USB device to the hub?

Did you reboot at any point? (You need to after the wifi name and password)

I think it only works with exactly the right wifi adapters that was in the note.

@jtmpush18 I brought the adapters that were recommended and they work but not very well for me. I ended up buying a WI-FI 6 TP-link AX1500 extender with an ethernet port and it been working without any issues for about a year now.

1 Like