Any problems with Sunset-based rules?

I have several sunset-based lines in a single holiday lighting rule and all of a sudden I notice that they are not firing when they should. The devices are still controllable through dashboard buttons and Alexa. Has anyone noticed a specific bug with sunset-based rules lately? I recently updated to the latest version and am still observing this.

1 Like

I have several rules based on sunset or an offset of sunset and all good for me on the latest few releases.


You need to check scheduling and event logs...

I have not. Neither on recent platform versions nor on the current hotfix, I think.

I have to preface I have been running a simple 10 device zwave net on Habitat C-7 hub for years.
I installed the latest update and my basic sunset -15min rule will not execute. I see some {Warn} in log I turned Debug on and saved. I do not see any additional information. I reset the time to browser time just to re-save the hub config. - I do have a Geosync rule on my Cell - I paused it. With holidays around the bend I would like the Holiday lights to work - Any suggestions would be appreciated... Also how would I backlevel this last update?

I'm experiencing something similarly strange with a simple rule to turn on some lights at sunset. I initially set it to turn on at sunset +30m, but am now at sunset + 0m.

In any case (and I keep tweaking the rule to try stuff out), my lights turn on at the appointed time, but turn off a few seconds later. To turn them on, I have to turn them off first, then on.

The logs show the turn on command at sunset, but there is nothing logged for the turn-off a few seconds later.


Oh, and I'm running the latest Hubitat FW as of roughly 01/08/23. Can't remember the FW version #...


Do you actually put in +0m or just leave it blank?
I leave it blank and don't have any problems in Simple Automation.
I wonder if that could do it, somehow?

Look at the device events not thr log yo see what turned it off. If nothing it was not hubitat maybe something else.

Tried that too. Same result. Thanks though!

No turn off event logged, just the turn on. And yet, every day, the same thing happens.

Can you post a screenshot of your rule? Anything else in the device's In Use By section?

1 Like

Is it in amazon . As well

I'm going to try changing it to 'Turn On and Set Level' for tonight. And then just 'Turn On' if that doesn't work. But I suspect that there's a bug with 'Turn On and Set Temperature'...

No, I don't think so.

Actually, I just got the Amazon Alexa Skill working today. There's an issue with that process too... It wouldn't find any of my lights. I would select all the switches and lights, and after hitting 'Done', it would ignore any lights. I had to select 'Respond Immediately...' (and possibly deselect 'Exclude Hubitat Integrated Hue Devices') for the Alexa skill to integrate any of my lighting.

If that doesn't work, would you try On at a certain then Off maybe 15 minutes later to see that works?

Well, it didn't work tonight. The lights turned on at sunset, then turned off several seconds later, one light maybe 3-5 seconds after turning on, then the other several seconds after that.

I'll try psudonym's suggestion to turn on at a specific time, then off several minutes later.

OK, the only option which works is 'Turn On'. 'Turn On and Set Level', 'Turn On and Set Temperature', and 'Turn On and Set Color' do NOT work. The lights turn on, then turn off several seconds later. 'Turn Off' may work too, though I did not try it.

It's one issue after another since moving over from Wink. I've got maybe 3 or 4 strange issues, like my dashboards not showing up on the app (just disappeared at some point), and strange sensor issues and other device issues. And I can't even get started on getting the 3rd-party Dashboard app going. I don't know how good I had it with Wink, except with its obvious failings (not local). It just worked.

Frustrated with all the quirks with Hubitat (though it does seem capable) and the need to constantly spend large chunks of time messing with it. And I'm a Linux guy and EE techie.

OK, it gets weirder. It seems that selecting a level other than 100 makes at least the 'Turn On and Set Level' selection work.

Anyway, it doesn't seem to have anything to do with Sunset/Sunrise. And may be peculiar to the Osram bulbs I have, which are the Generic Zigbee CT Bulb type.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.