Another Fibaro FGMS-001 ZW5 post

I'm using the built-in driver for the Fibaro ZW5 v3.4 motion sensors on C7

I'm trying to update config parameters like sensitivity and changing the LED brightness. But neither take effect.

I click save on the device page and the log shows that the commands will be sent the next time the device wakes up. So i click the B-button on the sensor.

Then I think the logs are showing that something thinks it is updating, but it's not? Notice how it keeps looping through changing 50 to 10 and then LED Brightness(#81) = 50

Motion Sensitivity (configVal1) doesn't stick either, it just always stays 15.

I also tried using the basic z-wave tool but those params dont stick either.

also, the WakeupInterval are set to 43200 even though the manual (page 11) says the default is 7200. any idea how to change that? the manual doesn't say what parameter number it is and the driver doesn't give any option to update it.

... and even though debug is on, i don't see motion/tamper events in the log. not sure if that's normal or if this is all one big related problem.

any ideas what's going on here?

Screenshot 2022-09-24 at 21-44-06 Kitchen Sensor

I can't remember if this particular device has a wake-up button but I know some of my vibration sensors (zigbee) will only change sensitivity if you press their button immediately before sending the command.

1 Like

@bobbyD can you share/is the built-in driver shared on github or some such?

All shared examples are in the public github:

Should work fine - I've set all mine that way. Open a separate logs page side by side with the device page while you program it and you can see the command sent. I think I needed to press the B button for each parameter sent using the Z-Wave Tool. I can't remember if I pressed the B button immediately before or after sending each individual command. Once I'd altered what I wanted, I cleared the log and used the command to read all parameters, so I could verify it was how I wanted. I then switched back to the built in driver and just left the preferences well alone to avoid overwriting anything.

these things are still acting wonky on me

Does your zwave details page show that it's in S0 security mode ?

The details page shows s2: 128 though.

I have 3 of these, i excluded and repaired them, they all behave/act/look the same.

@jkister I have 2 of the modules and my hub is C7:

The first I have included without security, as I have for most of my devices as that is the recommended setup (except for locks, entry, alarm devices). To do that I on the C7 I included it using my Z Wave stick (to avoid the C7 including it at S0). That one I use for my bed TV lift. There is no entry in the device data for 'S2' as it's set to none.

The second I have included specifically at S2 Authenticated as it can arm/disarm my intruder alarm system. That one shows a value of 131 for the Data, S2 entry.

Someone will confirm but I imagine that 'S2: 128' will show for 'S0' enabled devices.

You should avoid S0 inclusion at all costs (except for locks etc) as it is creates a lot of traffic on the Z Wave radio and will cause issues on your mesh. I was told about this, by those more experienced, when I first joined the community and had a number of Fibaro devices with S0. Unfortunately the C7 hub with a 700 series chip will force include the device at the highest security it can, if the device does not support S2. There's nothing Hubitat can do about that as it is what Silabs enforce in the SDK.

A USB Z Stick is your friend with regard to the above and makes it straightforward to include devices on the C7 with security set to 'none' rather than S0.

1 Like

I was curious why Hubitat never asked for the S2 security key. I had assumed it paired with no security until I just looked at that details page and saw S0. I understand S0 is evil.

@bobbyD can you explain why Hubitat includes this device with S0 automatically instead giving me the typical popup window that asks for the S2 key or cancel button to include without security ?

As I mentioned, it is down to what Silabs provide so there is nothing Hubitat can do to get around it as I understand.

Edit: though if it's an S2 device, yeah you should get the option....

1 Like

If you'd like technical explanation of why it's always S0, check this post:

If your device supports S2, but only includes with S0, you may want to check with manufacturer if an update is available for your device.

1 Like

Thanks. I just reached out to Fibaro.

That doesn't really explain, though, why @johnwill1 needed to use a z stick to include his with S2 instead of S0... if the z-stick can do it, shouldn't Hubitat ?

edit: oh, maybe his z-stick is not 700 series.

1 Like

Is the Z-Stick Z-Wave Plus v2 certified? Anything less is not apples to apples comparison.

1 Like

Apologies I've got my devices mixed up completely.....The FGMS-001 is the motion sensor, I was getting it mixed up with the smart implant :face_with_hand_over_mouth:

My Aeotec Z Stick Gen5 is a 500 series device. I do have several of the the FGMS-001's as well (mine are version 3.2). I had to use the stick to get those included without security.

Most of the Fibaro devices have needed to be included using the Z Wave Stick and PC Controller software to avoid S0. This includes Fibaro Motion Sensor, Smart Implant, Dimmer 2, Double Switch 2, Double Smart. I'm not sure they do any 700 series devices (but someone will correct me I'm sure)

1 Like

Just worked on this with the Zoos S2 Zstick 700 (paired without security). Used PC Controller to pair the FGMS-001 without any security-- worked perfectly. After a few minutes and a few clicks (may have been placebo, but Update on the PC Controller, Discover on Hubitat), the sensors all came online without S0. Yay.

So something's fixed it. It was either that it was included with PC Controller - or that it's paired without S0.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.