Another cry for help with Ghost Node

I had an Enbrighten Z-wave bulb that stopped responding to on off or dim commands. It occurred after we had a power outage. I figured it was time to replace it.
I did an exclude from the Device page - Add device - z-wave -then Start Z Wave Exclusion. I was able to get the bulb to exclude. Got back something like "unknown device excluded" and the bulb flashed. I then went to the light on the device page and hit remove device. I'm not sure, but I think I hit force removal.
The bulb is now unscrewed from the lamp so unpowered.
Now I have a ghost in my z-wave table.

I tried hitting Refresh, then remove (many times Remove) and several reboots with power off. The ghost still persists. I've hit the remove button so many times I swear I hear laughter coming out of the hub when I do.

I read many posts about ghost removal. I don't have a USB stick thingy that is mentioned is many of them.

I did try re-including the bulb and it did include include as a new device but still couldn't be controlled from the device page. I assume the bulb is bad so I excluded it from the device page and it excluded ok. (I guess that was the right way to exclude?)
The ghost is from the first instance of the bulb. Will not go away.

Any other was to do this besides getting the USB stick?

The Z-Wave details page

Since the bulb is powered off and excluded, try clicking refresh. If you’re lucky you’ll get a remove button, and clicking that, in a perfect world, should remove the entry completely.:crossed_fingers:

1 Like

Shut down the hub then unplug for 20 mins, then power back up and re try the ghost removal make sure bulb is off)

1 Like

I did that and have the remove button. Unfortunately, after MANY attempts it does nothing. The device still shows a route. When I reboot the hub the device shows the Discover button in the Device column and the Refresh and Repair buttons reappear. I can get the Remove button to appear with only one press of Refresh but then nothing.

I'll try the long power off. I tried the 30 second as advised in some of the other posts. The bulb is sitting on my dresser so unless Nikolas Tesla was reincarnated, no power to it.

The 20 mins will clear the z-wave radio. If that doesn't work you'll likely need a z-wave stick to remove it.

Didn't work so I guess I'll have to look for a USB stick.
Just a thought. If I restore an old hub DB to get the device back in the Device list and then do a Remove Device from the Device page, would that work?

Is this what I need?


@FLGuy Zooz 700 Series Z-Wave Plus S2 USB Stick ZST10 700, Great for DIY Smart Home (Use with Home Assistant or HomeSeer Software)
by The Smartest House
Learn more:

Thanks. On sale HERE if anyone else needs one

1 Like

Good to have, but even with my UZB 700 stick, it's a waiting game. Had to wait almost 3 days, for the mesh to settle? Finally was able to remove. Give it time, I have no idea why but someone pointed this out in another thread and he's spot on

1 Like

Day 4. Finally went away!!!
I ain't afraid of no ghosts.
Thanks to everyone for the input and advice.



At this point for giggles run a z-wave repair. Then from the settings menu shut down, unplug power (at the wall not the hub) for 20 mins. Then as an added precaution to eliminate the possibility of corruption in your current database, go to settings>>backup and restore. Click the DOWNLOAD button at the bottom of the page and save your database to your pc. (This will clean it). Go to yourhubip:8081, do a SOFT reset. Upon reboot, restore the fresh clean database you downloaded to your PC. (Don't restore the ones on the hub itself). This should put you in a good position all around..


I told ya, not sure what the heck is going on, but in our instant delivery world, waiting is out of the question. Makes me scared to even think about touching anything z-wave. Wonder if other Z-wave 700 hubs have the same issue? Is there even another 700 series hub?

At least one - from Vera/Ezlo.

1 Like

Ah, okay thanks. Bet they sold at least 20 or 30 of those :laughing: