Android Mobile App - Presence Greatly Delayed?

Presence has been working great for months on 1.6.8 build 128 on both our phones (both Galaxy S9). Just this week, though, it seems that there's a huge delay in the presence status update. This affects all sorts of stuff... thermostat, a bazillion lights, garage door, door lock, etc.

I thought it was just my phone being weird, so I checked permissions/optimization and rebooted. Didn't help. Then I watched when my wife came home and it took about 15 minutes to update on the hub dashboard (and then the garage door go up long after she had been parked in the driveway).

Any ideas for troubleshooting? Since it's both our phones I'm inclined to think it's either the hub or whatever is in between the hub and our phones (Hubitat server?).

Edited to ask: Does sending a Geo Event from the app show up anywhere in the hub/logs?

There should be events present in the phone app, Settings (gear) menu, Show Debug Information.

That should match at least somewhat close with the virtual phone device (your phone name) in the Device tab of Hubitat. Near the top of the page of this phone device has "Events" that you can look at. You also can or should turn on logs on that phone device, and see what the logs in Hubitat Logs tab says.

It's the Hubitat app that's not reporting. The beta has been working just fine for months for me and my wife and now it doesn't. I uninstalled and reinstalled the beta, but it still doesn't work for me. Wonder what changed... :frowning:

These are both identical Galaxy S9? So odd that one works and the other doesn't.

@bobbyD and @moncho1138 FYI

Yep, something changed on my phone, but I don't know what. It's worked for a long time and now suddenly it doesn't. There are other threads of people saying the geofence works in the beta, which is what we found when the last version of the app came out. I had to enroll my wife's phone in the beta in Google Play when mine worked and hers didn't. Now it's my turn, but I'm already using the beta, so... ¯\_(ツ)_/¯

So glad I searched here and ran across this thread. Same thing happening to me on my Galaxy S9. Had been working just fine on the beta, but sometime in the last 2 weeks stopped working reliably. Several times I have come home to my alarm system going off because the garage door opened and Hubitat didn't realize I'd come home. If I look at geofence in the app, it puts me exactly where I should be on the map - dead center of my geofence circle. I have found if I reboot the phone, it pretty much immediately tells Hubitat I'm home. Today I checked the logs - I left around 11:15 a.m. and was not marked as departed until about 10 minutes later. Since the beta has not updated, can't blame that. I wonder if there was a server side update that is delaying geofence events...

I have the same problem with mine and the wifes S21 presence been working awasome for months and the last week or so its been well off

FWIW, when my (non-Galaxy) phone updated to Android 12, I had to go digging for new switches to flip to keep the apps reporting. The key seems to be (again, on mine) Settings > Apps > Auto launch, and then enabling Hubitat to launch itself at boot and in the background. If this became an issue after a recent software update, you may be hitting the Galaxy version of the same setting.

1 Like

I though I was going crazy with the delayed presence issue. I use HE app geo fence and Alexa and macrodroid. To detect whether I'm home or not. It had been working perfectly until a few weeks ago. The issue is on my wife's phone too. I can arrive home or depart and none of the three sensors show a presence change . Then 45 minutes later (it can be shorter or longer or never) they all trigger at the same time. I thought it was my phone acting up because of a firmware update.

Update : I used an old phone I had just to test if it's a phone or HE issue. The result was the same delayed or no change in presence.

Think it's from a recent HE firmware update? I'd go back to an older version but I can't remember exactly when this started to happen. Anyone remember?

1 Like

I have been having the same problem for the last 2-3 weeks (of July).
I use the geofence on my Galaxy S8 to enable my alley fence gate opener to open and change the thermostat from away to the current schedule.
It was working great with only a few seconds delay, but now I have to sit in the alley for several minutes before I can open the gate!
I haven't really looked into the logs yet to see where the delay is coming from, but this is annoying!
Glad to see it isn't just my setup!

Samsung Galaxy S9 on Verizon here. It looks like we have a few Galaxy phones on this thread. I'm assuming we're all using the beta version of the app?

I know since the last update my phone has been removing permissions of apps I don't use regularly, but I've checked and rechecked location stuff and the Hubitat beta app. I've even reinstalled the app.

I did notice over a year ago that I had better luck with Hubitat reporting when I arrive if I used Google Maps to navigate home. Maybe that was coincidental, but that doesn't help now. I also turned location permission back on for Facebook (I hardly ever use it anymore, so why does it need to know where I am?), thinking that my phone might report location more often to apps that need it (not sure if that's how it really works, but...).

The Google map in the Geofence tab of the app shows the correct location, but the app will still report inside/outside incorrectly. Where is the Inside/Outside Geofence logic handled? Completely in the app, where it then reports to the cloud, then to the hub? Or location reported from the app, presence calculated in the cloud, then communicated back to the app and also to the hub?

Something changed somewhere. I just can't figure out if it's my phone, the Hubitat app, or the Hubitat server.

Wife and I just went to dinner and I noticed when we returned that my presence worked perfectly, but my wife's was still delayed. I had her move her geofence circle slightly, clear Habitat app cache and give permission for Physical Activity and Camera to match mine. We drove around the block and we both were marked away and then present like it used to. So, did that fix it? Time will tell...

(Why the Habitat app would need Physical Activity or Camera and why that would possibly make a difference is a mystery to me.)

1 Like

Probably Physical Activity. If you look in the Advanced Presence Options, there's a "Send presence only while in motion" option that's probably intended to save power by not re-checking your location if you appear not to be moving. Turn that on, then prevent it from telling when you're moving....

Came searching for this as I noticed it today. I've been using Life360 for geo since moving to Hubitat about 18 months ago. Why? Geo was broken in the Hubitat app at the time. Last week I got fed up with Life360 batt drain so I figured, "I'm sure they've ironed things out by now!"
Worked fine a couple days ago, then today it didn't work (but I may have just not left the house for long enough). No events received by the hub for that device. left again later, and about 25 mins (maybe more?) after gong outside the zone, it was detected. Yarg.

Anyone have suggestions about a better way of handling geo, since this keeps getting borked in the app, and Life360 causes quite a bit of batt drain?

1 Like

Could be. All weekend I've been marked away/present successfully since I made those changes late last week. :slight_smile:

People have had good luck with the beta app on Android, but that's what I was using for many months until something recently changed. So far, so good for a few days, though.

I use Combined Presence along with the iPhone WiFi Presence Sensor. That way, even if GPS geofencing isn't working quite right, at least it will change when my phone connects to the WiFi when I pull in the driveway. (iPhone WiFi Presence Sensor works for Android too and there's nothing to install on the phones. It just pings a device on the network to see if it's connected.)

BUT I much prefer the GPS geofence. The WiFi thing is just a backup.

I know there's several threads about this so I picked what looked like the latest one. I'm seeing the same issues with 1.6.8. I am in the beta group, using an S20 (android)

1 Like

Looks like everyone is using some flavor of Galaxy phone?

Here's my current theory: Check the permissions. I've had good luck since I allowed Physical Activity and Camera permissions. I might remove them individually to see if one of them was the magic permission that broke stuff.

Not for my device - both are enabled as well as no memory optimizations (ie: allows OS to save battery by not letting the app do as much in the background)

Samsung has really been messing ng with stuff. Spotify was acting goofy the other day. A little googling led me to several setting regarding battery usage. And clearing free memory I'd never messed with before.

It may be worth a Google search to see if there are more settings that can be adjusted.

I am not sure about those specific permissions and how it affects Hubitat. But the last couple times I have updated my apps (I do not allow auto updates), Google Play app helpfully pointed out that it had "removed unused permissions" from certain apps. It said something to the effect of "you have not used these in XX number of days" and that is why they were removed.

There was a reason I had those permissions set/allowed/blocked, but Google apparently knows better than myself or the author of the app what permissions are needed??? No wonder things are breaking.

1 Like

Download the Hubitat app