Android 2.0 Beta - Notifications

I am testing version 2.0 of the Android mobile App and I noticed a few things relating to Notifications.

  • The date/time for a notification is in UTC, not my local timezone, so +0 instead of +10 at the moment
  • The name of the tab at the bottom of the app is Notifications, but the title at the top, when displaying that tab is Alerts. I don't mind which is used, though Notifications is more consistent with other parts of the platform
  • There is no way to look at the longer version of a notification (that I can work out), i.e. if a notification is longer than what can be displayed in the list or on the recent notification tile on the Home tab, then I can't find a way to view the rest of the notification

Longer notifications will be visible with a pop up on next build


I'm not getting any notifications at all with the 2.0 version of the app.

Notifications are enabled, but nothing is coming through.

I just did a test of the Device Activity Check app.

I then viewed the (phone) device properties in Hubitat and I can see the notification, but it never made it to my phone.


Edit: Had to delete my previously defined device and create a new one with the same name in order for the notifications to start working.

That's weird, I would not have expected the notification to be delivered based on the name alone ...

I think the name is coincidental.

I noticed the Device Network ID for new device is significantly different than the one that worked with version 1.7.2 of the app (before I deleted it).

The 2.0 version of the app would not work with the device that was being used with version 1.7.2 of the app.
Had to generate a new device with app 2.0 to get it working.

1 Like

After reading your posts, I tried to rename the device from v1.7.2 and start over. I cleared v2's data and started it again. After logging in it prompted me to create a new device but did not prompt me to name it. I think that's how it worked on the old app too. So now I've got a device associated with the old app and a different device associated with the new app.

Both times I tested it I noticed that the app did not prompt for permission to send notifications so I had to go into settings to turn that on. I think I've finally got it all straightened out.