Amazon echo skill

Hey guys, having a problem with amazon echo skill.
I had multiple devices before working with amazon echo skill before but lately tried to add 2 light bulb devices but they don't show on alexa app. Tried a couple of things such clearing cache, unlinking and linking hubitat skills and still no luck. Yeah I did added on the dropbix on echo amazing skills on hibits but still no lucky. Any suggestions please?


As I've seen one guy not being able to add it because he wasn't adding the device to the amazon echo skill app on hubitat. Like I know I have add it into the app. Just don't know why devices are not appearing into the alexa app as used to do before. All the other devices are there but the new ones are not showing

Did you click “Done”

1 Like

Yes I did and that's basically what I was trying to say. I clicked done and checked if it was added and everything is fine there. Had other devices added before with no issues in the past. Even unlinked the skills on alexa app. When I go to link it again the devices shows on the list there to authorise and everything but after that doesn't show on the device list on alexa app

Alexa does not handle all the device types that hubitat does. What kind of device are you trying to add?

1 Like

It's just one exctaly type of a zigbee light bulb I have in my whole house and all of them works fine. Tbh been trying to figure out things here to see if I can come up with a solution and tried to add a virtual device to see if would appear on the alexa app but that didn't work either and have few of those working fine as well. Seems that just the new ones are not being discovered

It sounds like Alexa is not receiving the update request when you tell Hubitat to add the device in the Alexa echo - that could be more of an IP networking issue . Or Alexa was having a snit at the time. You try removing the device in the hubitat echo setting, hit Update and then Done. Give it a few seconds and then try the add again.


Thank you. Being honest I've been trying to get this sorted for the last 3 weeks and already done that as I've seen someone suggesting it and still no luck at all. Never had a problem with it and alexa would discover straight away before

It is highly likely that it is something unique to you since many, many more are using Alexa without this problem. You'll have to think about what has changed in the last 3 weeks. Perhaps Hubitat changed it's IP number since the Alexa Hubitat skill was installed on your phone. You are using a DHCP assigned IP # ?

1 Like

Thank you once again. I'm trying to think. Only thing that I can think of is that couple of my months ago had power cut out in my town for like 2 hours and then had problem with my hub and the ip the o acess now is different. Also just went into the logs of echo skills and saw something in red saying error making Call to Alexa message gateway and also something about something acess token is not valid. Anything I could do to fix that?

Ah, the error log! I just assume people look at it before asking questions on the forum. I should stop assuming that. Anyway, that power fail recovery could have assigned a different IP number for Hubitat. You need to have your router assign a DHCP address so it's always the same number after router reboots.

Errors about the Alexa gateway: Exact Error messages are very helpful. Notice how many people include a screen capture of their error message when they have a problem? I suspect you are going to have to re-install the alexa app and skills on your phone. That can be a pain in the behind so don't do it because I 'suspect'. Somebody else can advise on that or you can search for other reported problems with Alexa and that error message.

1 Like

I'd have no problem u installing everything. Tbh if that would fix. What I still don't get it is when I unlink the skills and go to link it again the name of the devices are there for to authorise them. They just don't appear after and are not discovered on the Alex app

Yup, the devices do not disappear from Alexa when the skill is removed - that is a bug or a feature in Alexa - I lean towards feature when I think about Alexa routines that use those names that would have to be redone if the name disappeared. If I remember correctly, they are re-discovered and recreated by Alexa if hubitat gives Alexa the list. As far as I know Hubitat only tells Alexa what is new when there is a change in the Hubitat Alexa app and you hit the done button AND assuming Alexa has the IP # Hubitat thinks it should have.

I don't know if it part of this problem or not but the phone registered with Hubitat would also benefit from a DHCP address set by the router.

1 Like

Thank you for all the replies. I really appreciate it. Despite everything is there any solution to get it back working?

You have not said whether you have DHCP assigned IP address for your Hubitat hub and the phone you use with Hubitat and Alexa. You'll have all kinds of weird problems like this one if you do not.

1 Like

Take a local backup of your hub, and download it to keep it safe… (Always a good idea before making a bunch of changes!)

Then, I would Disable the Hubitat Skill from within the Amazon Alexa app on your phone or tablet. Next, REMOVE the Amazon Echo Skill app on your Hubitat hub. Reboot your Hubitat hub for good measure.

Delete all “Hubitat Devices” from within your Alexa mobile phone app’s Smart Home section.

After you hub is back up and running, ENABLE the Hubitat Skill from within your Alexa mobile app on your phone or tablet. This should require you to log into your Hubitat Cloud account to choose your hub. Doing so wil automagically install the “Amazon Echo Skill” app on your Hubitat hub, which will then allow you to select some Hubitat devices. Try just a few and make sure to click DONE. Check to see if these devices appear within the Alexa mobile app on your phone.


I tried to create a routine last week and I could not find the virtual switch that I just added to control the routine. I clicked on the plus (Add another action) to add the device to my routine. clicked Smart Home. I clicked "Switches" thinking it would be there. The device was not listed. I realized that at the bottom of the device list was "... All Devices". I found it there. So...
"+" (Add another action)-> Smart Home -> ... All Devices

Thank you so much that ended up fixing my problem. I really appreciate it

1 Like

Great to hear that Alexa is working again! Have fun!