Amazon Echo Skill not working

I installed the skill, not the app, when I go to Alexa app in my tablets to add HE I can find the app, I can login, I can select my hub, but I get an error that I must be on version 1.1.0 or higher, I'm in the latest version.


Edit: I tried with the Amazon Echo App and I get the same error. :sob:

What hub firmware version are you on?

I upgraded to yesterday and started having issues with authorization of external services later that afternoon. I'm not sure if it's a firmware thing or something else... immediately after upgrading the firmware, I was able to authorize external services, so it may have just been bad timing, but it happened on both of my hubs shortly after the firmware upgrade.

I been on from the day it was released. I started to play with Alexa last night, then this morning and the same issue. I'm a Google Home user but my tablets are Amazon so maybe I can disconnect the ST hub and use Alexa until HE get Google Home integration. Thanks for answering.

Contact @bobbyD. I experienced the same issue. The fix was very inconclusive unfortunately, but in a nutshell, I reverted back to an earlier version, then went back to the latest (this was pre-114) and I was able to install it again.

But contact Bobby before you do anything. He might have a handle on the cause and a solution now.

Thank you.

1 Like

Well now Iโ€™m getting this as well. Was trying to reinstall the skill but canโ€™t now.

Me too...everything was showing up Offline, so I disabled the skill and tried to enable it.

Emailed support. Hopefully its something they can resolve.

I did not email support yet. I will do it now.

Tried to fix by removing and enabling the Hubitat skill skill bit know can't enable the skill due to the hub version error message.

I received an email from @bobbyD

Here is a quick update on your Hubitat Elevation support ticket. We identified an issue with our 3rd parties authorization process and your ticket has been escalated to an engineer for further research. We will follow up with you in the morning to provide more details and resolution times.

We are very sorry for the inconvenience that this may have caused and we are doing everything we can to resolve your issue quickly.


It should now be fixed. I was able to add the skill this morning.


I can confirm it now goes to the next step, but Alexa is not discovering any devices. Can anyone confirm?

I cant send commands via Alexa to my hub to control devices, not sure i should remove the skill and then re-add it in case it doesnt work at all. I am sure support is aware and working it.

Yup.. just tried to discover my devices and it too wasn't picking them up. Still not working.

Unfortunately I won't be able to troubleshoot it until later tonight.

There was an issue with the authentication server and it should be resolved. You should not need to do anything as it should try to connect again and normal functionality should resume. If not please reach out to support.

Anyone else seeing errors with the Amazon Echo Skill? Devices still turn on/off with voice commands and seems to be working fine, not sure what these are about?

I'm getting this error message, whichever the device I have selected in the Echo Skill app:

2019-07-08 01:09:09.925 am [error]( Cannot invoke method toLong() on null object (updated)

--- Live Log Started, waiting for events ---

Amazon Echo Skill does not work. Amzon Echo App works, but doesn't take my lock nor thermostats.

Getting this one on

Any idea how to debug this?
Is this a particular device in the list of echo devices thatโ€™s misbehaving?

app:5142021-02-01 04:24:59.877errorError making Call to Alexa message gateway: {"header":{"namespace":"System","name":"Exception","messageId":"ASRLS_ac394bb7-d9da-4ca9-b10e-999d87e232e3_1612182299399.0..ASRLS_ac394bb7-d9da-4ca9-b10e-999d87e232e3_1612182299399"},"payload":{"code":"INVALID_REQUEST_EXCEPTION","description":"Cannot read the request payload as: Cannot construct instance of, problem: value\n at [Source: UNKNOWN; line: -1, column: -1] (through reference chain:$V3Builder["context"]->["properties"]->[3])"}}