Amazon Echo Skill not working with devices using capability "RelaySwitch"

I am working on a child device driver was trying to get it to report to Alexa as a Switch instead of a Light, so I tried to use RelaySwitch which worked great for the google skill, but then on Alexa it just gets totally ignored, does not show up in the Alexa devices at all. If I change the capability to Switch and removed and re-add the device in the Echo app it shows up on the Alexa devices.

Side note, I think I figured out that by using "Switch" and removing "Acutator" (I have no idea why every switch driver has this anyway) it will show up as a switch.

is there a reason you cannot just use capability switch as a workaround.

i think actuator is separate i use it in the tesla device handler .. it lets you call custom commands like
command "startCharge"
command "stopCharge"
command "openFrontTrunk"
command "openRearTrunk"

in rules i pick actuator then the tesla device then the custom commands are available to be called.

most likely actuator is in these drivers if there are any custom commands.

When using both the Capability Switch and Actuator it seems to get reported to reported to Alexa as a light for some reason. When I remove the Actuator capability then it gets reported as a Switch... the apps logic is a mystery to me.

Good point on the actuator with the rules, I will have to test that as I was just about the remove the Actuator capability from all my switch drivers but it sounds like it might break something.

Even with the Actuator capability removed, I can select Switch and select custom commands from there on this device. So I think you might only need Actuator if there are no other capabilities that would have commands. I am going to run with it removed and see if it causes any issues.


Download the Hubitat app