Amazon Echo Skill not working since Friday 1/20/2023

Had to delete off my hub as still in error one of many issues that still are not resolved

Thank you for the update. That indicates the problem may have been on the Amazon side. But we are still investigating to make sure the problem wasn't on our side.

1 Like

My guess is that someone at Amazon realized that they unplugged the server instead of the candy machine :rofl:


Or they let the guy keeping the server running go in their job cuts!


Glad to hear it. Thank you for the update. Hopefully, it keeps working reliably.

It’s Amazon, so who knows anymore. I think they have been hard at work trying to monetize Alexa because lately she’s always trying to sell me something.


YES! The "By the way..." has been getting more aggressive I think. I just yell back at it to shut up and just do what I told you to do. Maybe it will get the hint (probably not but its fun anyway).


I found out recently that "Alexa stop by the way" will get it to stop for a while. It responds, "OK. I'll pause notifications for now." I don't know how long it will last, but I'm going to cherish every minute of it.

1 Like

Awesome, just tried it and it says "I will snooze my suggestions for now"

I could setup a rule in RM using echo speaks to send that command once a week, I just tested saying it a second time and it responds the same so no harm in sending it too often.

You can also go into the notifications section of the alexa app, select amazon shopping, and turn off "receive personalized recommendations based on your shopping activity." Not sure it stops 100% of the stuff but seems to work for me.

As of right now mine is still not working, I may try deleting the app in HE and retrying.

sys:12023-01-23 05:50:52.540 PMwarnReceived cloud request for App 135 that does not exist, path: /device/144 from

sys:12023-01-23 05:50:47.447 PMwarnReceived cloud request for App 135 that does not exist, path: /device/144 from

Yes you deleted the app in Hubitat but the Skill on Alexa is still trying to talk to your hub.
You need to disable the Alexa skill and then re-authorize it.

1 Like

i did, it recreated the hub app then i get that

Leave the app on Hubitat alone there is no point in deleting it really.
Disable the skill in alexa, delete it or whatever it calls it.
Enable it again and log back into Hubitat, hopefully it will grab the correct app ID this time.

That doesnt solve anything.
Its still looking for App 135, but as far as I can tell the Echo app in HE is 159

Then not sure what you have done, possibly another app that was deleted which links to devices?
You could scroll through the past logs and see if you see any old log entries from App 135 which may help figure out what it is.

Check the last two posts here for another way to figure it out

One more thought, Go to Settings >> Network Setup >> Click Network Test
Use the ping test but type in instead of the IP listed and try to ping that.
If that doesnt work your hub cannot resolve host names.

1 Like

Good information ,but I fixed it in another way, not fully sure why but my guess is i tried to integrate during the outage and that caused issues.

Anyway, what I had to do was remove the HE app, then unlink in Alexa, and THEN remove each device one by one. Once I did that, I added two devices back and it worked, but then tried to add the rest and it failed. I think part of that was to many devices so I added them in chunks and that seemed to do it.

Ahhhh this has been driving me mad for a few days now (actually, more like driving my wife mad who then in turn drives me mad...)

I've been trying to debug this one for a few days and just now I am certain my problem is Amazon itself.

Weirdly if in HE I remove or add devices to be exposed to Alexa I get Alexa notifications on my phone that the devices are added or removed.

I tried removing the device I'm having grief with (I only actually use one HE device with Alexa, a virtual switch) and adding it back - I get notifications of this just fine, but the device is unresponsive it says and it doesn't work at all.

Its got to be Amazon --> HE cloud issues hasn't it?

Obviously I can't see the Hubitat cloud or Alexa cloud to look at logs though...

Actually, think I've fixed it.

I noticed my C7 said it couldn't reach the cloud when I click on the speech bubble top right. No idea why that would be, it was fine and happy, the network tests (as described above) worked, DNS resolution was fine....

I tried a hub reboot.

Its back, its working, Alexa is working.


1 Like

Download the Hubitat app