Alfred Lock Issue

I did do a search but my issue seems to be a bit different. I have the latest Zwave module from Alfred and the lock paired without any issues. If I manually lock or unlock the door it reports the status right away so I know it's connecting. However, I can not get HE to lock or unlock the door. Is there something I'm missing?

Hi Devin. I have two Alfred's. Is your battery going dead really fast too? What hub do you have?

I have two Alfred locks as well. Originally, I had them setup as generic Zwave devices, as there was no driver yet, and the one worked fine but the other one did drain the battery really fast so I just removed the Zwave module from that one. I lived with it like that for a long time but recently got back into automating the house so I contacted Alfred and they sent me two new Zwave modules with the upgraded firmware. With the new modules the battery no longer drains really fast and I have it setup in HE using the new Alfred driver. It paired easy and defects the status fine just can't lock or unlock it.

The second lock when I go to pair it tells me connection successful right away so I need to factory reset that one but don't want to loose all my codes so haven't yet.

I have the C4 hub.

Ok .. I had the same problem. Before I say this, I'm going to tell you that my 3 zwave locks hit EVERY time. I have two fred's and one schlage. Because of how the locks work, they need a repeater of some type that supports beaming. There are switches and plugs that also support this, but I added 3 aeotec repeater 6's to my mix and placed one close to the hub (maybe 3-5 feet away) and one right on the other side of the wall from the schlage lock and the other in a back room on the other end of the house. You can't pick the route your z-wave is going to pick. You can only make one route look better than another and then there's really no guarantee. Z-wave will only make 4 hops to the hub and then back. So, since I added the beaming repeaters, I've not had any issues. I got the freds in February. If that says anything. Check your devices and see if any of them supports beaming. If not, I'd highly recommend getting one that supports it. I had to move the repeaters around a bit to get them to like the routes, so it's a bit of hit and miss, and patience because zwave plus self heals. I have a zniffer, so once I saw that the locks were routing through the repeaters, then I moved on to address the ohters that weren't responding. It'll take some time.

And I know that it's recommended to reset the lock, but don't. You can pull the codes from the lock in question. Just remove the lock from the door and take it to the hub and pair it right next to the hub. Do a generic exclude before trying to pair. Don't reset. Then put it back in the door. You'll have to run a repair after, but make sure it pairs secure.

Oh and I also have C-4's

Thanks for the info. I don't currently have any repeaters, is the Aeotec the one you'd recommend?

That's the one I use. I had an off brand plug that supported beaming, but it ended up going bad, so I've just got those and they have worked well for me. The light blinks when something routes through it. People have had good luck with these and locks. I know mine are running well. There's a two pack out there for like 50$ on amazon I think. That's the best deal that I found.

I hooked up one repeater, paired everything again, repaired network and now it all works. Thanks for the help.

1 Like

Hello, I'm really hoping one of you can help me out since you have experience with Alfred locks... I recently purchased the Alfred DB2 and had issues with the original z-wave module. Alfred sent me a new module which I received today... when I started the z-wave inclusion process, everything seemed to be going smoothly... until it got to the part where it asked me to enter a 5 digit code... I was totally unprepared for this and had no idea what number to put it. Eventually I pulled the module out and found what looks to be a QR code as well as a number... well the QR code displayed a very large number and the instructions were asking that I input the first 5 numbers... but there was also a number printed next to the QR code... I didn't know which one to try and so I tried the long version one... it didn't seem to do the trick. Or rather, by that time it may have been too late, plus pulling the module probably invalidated the entire thing... immediately after that, I did not see anything under z-wave devices for the Alfred. However, I just tried rebooting my Hubitat... after that, I now do see an additional line item in my z-wave details page... but the "refresh", "repair", and "discover" buttons don't seem to do anything... I also tried include and exclude again as well to no avail... any thoughts or ideas on what to try next? Also, do either of you know how to "reset" the z-wave module? I see a pinhole on the module, but it doesn't seem to have a "button" underlying it... meaning, nothing really to "push" on... any guidance would be appreciated. Thank you in advance. ! AlfredZwave|690x411

Some additional info in case it helps... I have a C-7 hub on The hub has direct line of sight to the Alfred lock at around 19 feet away (but no obstructions). The only other z-wave device I have is the Inovelli Fan/Light switch as you can see in the screenshot I included in my first post. That fan/light switch is even closer (around 12 ft) in distance to the Alfred lock, but just behind 1 wall.

I never had to enter a number for mine so not sure about that. Alfred told me that the only way to reset the zwave module was to factory reset the entire lock with the zwave module installed. I never ended up having to do that. I'm pretty sure the lock needs to be closer for it to securely pair it though, like 6".

Thanks for the quick reply! Strange you had no numbers come up during inclusion... I thought it was strange as I never came across such info in instructions... I wonder why I got that... I didn't know about the distance being a factor (even when one has line of sight)... maybe the distance is what's causing such glitches? Btw, do you really mean 6" or did you mean to type 6'? Also, is it completely taboo to bring the hub to the door lock instead of the door lock to the hub? I think it might be easier for me to do that rather than disassemble the lock... Also, the factory reset option is something I'm considering as well given I haven't yet loaded my family's codes into it... I only did mine as I was waiting for the z-wave module so I could do everything through Hubitat Lock Manager... any recommendations on which to do (or not do for whatever reason)? Thanks!

I read somewhere it was 6" but not sure the exact distance is just for secure pairing it needs to be closer. I took the hub to the lock when I did mine. Check if zwaveSecurePairingComplete is true:


I received a reply from Alfred Support after providing them the same info...

"The 5 digit inclusion code is the one shown under the QR code. This is a Zwave S2 security process which many hubs are now starting to implement.

There is no module reset button but resetting the lock with the module installed should reset the entire system on the lock side, Zwave included. You may have to do a force remove of the lock from your Hubitat first but then retry adding the lock with that 5 digit number handy and you should be good."

So it seems that the 5 digit code thing was legit for Z-wave "S2"... it must just be so new and why I did not see any instructions on it anywhere. It's a shame because I'm pretty sure the process would have been completely straightforward had I known about it.

So for anyone about to install Alfred with Z-wave (S2) module, know that you should take a photo or write the code down prior to installation. Because once you put the module in, you can't see the code as it's on the back side.

At least for now, I'm going to assume that the distance from hub to door lock was not a factor (in my particular case) since it connected right away... it was the code (or lack thereof) that sent things downhill.

You were correct about the reset as well. That may be the first thing I try later today.

Oh, and regarding your last screenshot... I can't even see such info because I'm not to that point yet. There is no "device" to view in Hubitat...

1 Like

The C-7 is the first Hubitat hub to support S2. The C-3,4,5 support S0 which is usually required by Locks. Therefore, in this thread, you're the first to be trying the Alfred with a C-7 and thus the first to encounter S2. The Include process has two popup screens, one with a set of buttons for S0 and S2 Unauthenticated and S2 Authenticated, etc. When you pick S2 Authenticated (or it defaults to picking it) then the NEXT screen wants you to put in the Code. Yes, the code is always printed somewhere on the device and that's always going to be inconvenient :slight_smile: IF, you deselect Authentecated, it doesn't ask.. and better yet, it prints out the whole string, including the code you would have to enter.

Oh I see... thanks for the info. That explains why that information is not seen anywhere! Your description of the process is exactly what I encountered and I just went with the "default" settings on the first popup screen and then came to the code screen... Are you suggesting I "deselect Authentecated" or should I just go with inputting the code now that I know the process? What are the pros/cons of deselecting vs. not? I want to make the right choices on this next round! Thanks.

You should use S2 Authenticated, but if you have truly lost the code.. the last resort way of finding it is to deselect S2 Authenticated... then write it down, and start all over in the Include process, this time using S2 Authenticated :smiley:

I have 2 Alfred locks that I just installed zwave modules into. Both on the main floor with the hub. Each are about 15-20 feet form the hub. Hub is a C-5. One lock paired easily, and securely. I can lock/unlock fine and it reports perfectly. I have no tried out any more sophisticated things yet. The other one however, will not pair securely no matter what I do. Distance does not seem to be the issue as I have swapped the modules around and tested it.
I contacted Alfred yesterday and they told me to unpair them, do a factory reset and then be sure to use the security codes when I paired them again. But I can't use the security codes!

Well, I factory reset everything a 4 more times and now both locks are reporting and working fine, so who knows what the problem was! Typical smart home gremlins I suppose. In any case I'll try and test out some automatons this week to see if other features are working.

Okay everyone, thanks for all of the input. I successfully reset the Alfred lock + z-wave module to factory settings, ran z-wave inclusion on Hubitat and it showed up right away and I was able to input my code... however, it did hang a bit on the inclusion process... but with a bit of fiddling and some "repair" and "refresh" on the z-wave details page, the process eventually finished and allowed me to save the device. So now I'm on to using (or at least attempting to use) Lock Code Manager in Hubitat... I've seen so long posts on that topic elsewhere so I'm not sure I'm looking forward to it...

I spent 7 hours today (10am-5pm), finally I got this working. Wanted to share my experience here. I have the C-7 model with platfiorm version and Alfred latest firmware DB1V2.01. It takes me several tries to get first inclusion successful completed, HE refresh ok when I physically turn to lock/unlock, but pressing the on/off button in HE won't work. Then, I unpaired/removed the device, factory reset Alfred. After so many attempts, I was able to get second inclusion complete. This time, it was completely opposite, pressing the on/off buttons in HE work, but HE won't refresh itself, I had to press the refresh button. This second case was the same issue I had when I setup all my Inovelli switches, I resolved the switches issue by unchecking all the security questions. So, my guess and hope that doing the same for Alfred will fix the issue. So, I keep trying to exclude, factory reset Alfred, then include again so many times, each time I choose different security questions, 1) Uncheck all; 2) Only S2; 3) Only S0. Unfortunately no success. Either no refresh or on/off won't work. I almost give up after doing this for 6.5 hours. Then I decide to give it a final try and leave it overnight, I see that the log sometime say hub busy, may be when the hub catch up, it will work. On my last attempt, I decided to keep the original security setting, that is S2 and S0. Magic does happen, it works perfectly this time. So, my conclusion is that it is a very buggy software/firmware. I don't think it has anything to do with the security questions. I have done over 40 times "exclude, reset, include" in order to get it working. Yes, you have to do the factory reset every time, otherwise HE will create the note, but won't create the device. Also, check the setting, Z-Wave details each time, make sure the node was not created there. It happen many times that HE created the node, but timed out on creating the device. So, I need to force remove the node and reboot HE each time. Deleting the node is painful process too. You need to remove the battery from Alfred, refresh HE until the node show status UNKNOWN or FAILED, This is the only way to get the remove button to show up. Once you pressed the remove button, you need to reboot HE in order to get ride of the node. This is why each failed inclusion will take me 10-15 minutes to reset everything. After 7 hours battle between Alfred and HE. Finally I got both talking.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.