Alexa won't dim bulbs

I've had my Habitat up and running on a limited basis for about 2 weeks while I tinker with some things. I Started with devices that were rejected from the new ST app. I have most running the way I want so i added a Cree and a Singled connected bulb to the mix. For any automation platform to work in our house, it needs to work with Alexa (wife's rule) I have excluded the affected bulbs from ST, and added them to HE., then went into the Alexa up on my Wifes account and discovered devices, and added them. I am able to have Alexa turn these bulbs on and off. However, when I try to have Alexa dim these bulbs I get a response they cannot be found in he profile. She was able to dim then with voice commands on ST. Has anyone run into this? Were you able to fix it? or any suggestions? Thanks !

Check in the Alexa app to confirm that they were discovered as lights.
Sometimes bulbs get discovered as switches (hence on/off is ok)


1 Like

Ahh, didnt think of that... thanks !

Worth a try! :slight_smile:

Also, what country are you in? If possible, you should be using the ‘Amazon Echo Skill’, which is installed automatically when you Enable the Skill from within the Amazon Alexa mobile phone app. Doing so, will add the corresponding Hubitat “Amazon Echo Skill” app on your Hubitat Hub.

If you cannot add this Skill, you are probably not in a country where it has been released yet. If so, the you can use the older “Amazon Echo App” by adding it manually on your hub. This app emulates a Philips Hue Bridge to allow your Amazon Echo device to discover it. This old integration only supports On, Off, and Dim.

Please do not install both integrations as it may lead to duplicate devices discovered by Alexa, causing issues.

I am in the US. I'll have to take a look and see but I am pretty sure I have the Amazon Echo Skill installed. At one point I had the app, but someone told me that was for the UK?

The Amazon Echo Skill if available in the US, Canada, and UK. The Amazon Echo App is required for all other countries at this point if I'm not missing a country where the skill is also available.

The fact that Alexa gives odd responses about what is and is not dimmable or available for Hue doesn't surprise me. I have had it give this response for the Hue Skill on Alexa, for lights that I've been controlling for two years with Echo and Hue! It sometimes seems I get these odd responses that just don't make sense. I'm guessing Amazon have screwed some things up with the recent overhaul. I know my Alexa app is stupid slow. I really don't like the update they've done. These changes have not been helpful to me, and have only made it harder to configure things becuase of how much slower their already dog slow app is now.

I just two days ago had to figure out a way to use a virtual lock driver and IFTTT to get status on my August Smart Lock. Lock status with Wink has been working in Alexa for well over a year with no problem, and suddenly it says the lock doesn't support that. Removed and re-added to no avail. But the HE Virtual Lock Driver does work for Alexa status reports, so I'm using IFTTT to flip the HE Virtual Lock Driver when the August lock state changes. So it's very likely the issue you're experiencing isn't Hubitat, but rather an issue with Alexa Voice Services.

The one good thing about this recent issue and solution I came up with is I can now unplug my Wink hub too, because it serves no purpose for me now.

Weirdest thing. I couldn't get back to try some of these suggestions for a couple days. When I finally was able to tinker with it, they started dimming just fine. No idea what changed, but I'm not complaining ( and neither is my wife)!

1 Like

Probably something in the Amazon cloud. It’s cool that they’re always adding features, but that means that things don’t always run smoothly 100% of the time.

1 Like

I am using the Other Hub integration and having Alexa control my SmartThing devices. However, I could never get her to set the levels of lights. So I tried the native Alexa App and for some reason I kept loosing the connection.

I cannot get the Alexa Skill going for some reason. I deleted the Alexa App and now, Alexa doesn't discover anything associated with Hubitat anymore.

I am sure that my password is correct as I get to the screen where it say select the Hub...


Use the Alexa Skill.
The Alexa App is for those places in the world where Amazon has not approved the skill.

Do NOT use both.

I started off using the built in Alexa App in Hubitat when there wasn't an Alexa Skill. I deleted the Alexa App in Hubitat and tried enabling the Alexa Skill through the Alexa App. I can not link for some reason. Today, I tried another method and got this error:

I have alot of Alexa devices and had a hard time initially with Hubitat turning off devices that shouldn't have been turned off. I switched over some more devices to Hubitat that I really need voice control over light levels. I am dead in the water now...

Usually, if you cannot enable a cloud integration, like the Hubitat Skill for Alexa or the Hubitat Service for IFTTT, it means that your hub is not registered correctly with the Hubitat Cloud Server. A quick email to is the fastest way to get this resolved.

Using a DHCP Reservation in your router for the Hubitat Hub will also help to make sure things run as smoothly as possible.

Thanks. Sent them an email.