Alexa voice command issue after switching to Hubitat


First, thanks to all who helped me with my newbie questions earlier on. You alleviated confusion well- and also helped me kick my brain back into gear after making a pretty stupid mistake.

Hopefully, this problem will be easy, as well:

First, the hardware. I'm running a stand lamp off a plug-in Schlage RP-200 Lamp Module (dimmer). When it was on my old Nexia setup, I could use voice commands to set dimmer levels ("Alexa, set Front Door Light to 50%.")

Now that I'm on Hubitat (the type is set to generic Z-wave dimmer, as it was closest to what I have), I can no longer use voice to set dimmer levels. The previous command gets the response "Front Door Light doesn't support that." However, I can use voice to switch the light on and off. (I have an Inovelli dimmer for an overhead light that is set up as the same type of device in the Echo app, that does dim properly.)

The only thing that has changed seems to be nixing Nexia. This makes me think there's something I can change in Hubitat to get it working. Any ideas?

Thanks very much!

1 Like

So dimming works properly from the device page, it is just when you share it to the Alexa skill that voice commands don't work? Also how does the device appear in the Alexa app, compared to the Inovelli dimmer for instance?

Yes, the only problem is dimming with voice commands on the plug-in module. The two devices appear precisely the same way in he Alexa app (both show as lights).

It's really only a minor inconvenience. However, I'm now a little hell-bent on solving the problem. :slight_smile:

Yeah I was just trying to make sure it is a problem with Alexa only and not a problem with the driver you selected. Have you tried unsharing it, deleting it from alexa, resharing it, and discovering devices?

That's kin do of why I made a point of saying the only thing that seems to have changed is taking Nexia out and putting Hubitat in. I feel there's a smaller chance it is an Alexa issue. I've rediscovered the device A few times in the course of setting up Hubitat bit by bit. I can always do that again just to see if it jogs anything.

Yeah because there is no reason it shouldn't be working, I can't say I have used the Generic Z-Wave Dimmer driver, but I have plenty of dimmers, mostly virtual dimmers, shared to Alexa and they work fine. Also in the Alexa app can you adjust the slider to change the dim level or is that broken as well?

Also have you taken a look at your Hubitat logs to see if there are any errors?

I can easily change the dim level via the slider in the Alexa app.

Just for fun, I just changed the driver to generic z-wave smart dimmer. No pun intended, but the situation didn't get any brighter. :frowning:

That is very very odd, that sounds like an Alexa issue then more than a Hubitat issue. Have you tried swapping from Light to Switch type in Alexa to see if that helps?

No. It will not let me change the type.

Just checked the logs- no issues, except with the smart lock that is a known issue right now.

That is weird, it definitely should allow you to change the type, the only time I have seen it locked down is with smart bulbs. Then again, I have never used Generic Z-Wave dimmer driver, so a grain of salt should be applied.

Edit: I just checked and now all of my dimmers and bulbs shared via Hubitat are locked down to light versus my switches are given the choice (unless there is light in the name, in which case it locks it). I wonder what was changed.

Stupid suggestion, maybe it is an issue with the voice recognition of the name. You could try renaming to something unique and simple and then see if the error is still there.

It sounds like you have been able to pair the RP-200 with Hubitat. I do not know if the generic Z-wave device driver fully supports the device.

Are you able to control the dimming function through the Hubitat device manager? If you are not able to dim the light within Hubitat, there may be a driver issue, either in the settings or the generic driver might not be compatible. You might be able to use another Z-wave dimmer driver, either one built directly into Hubitat or one of the customer drivers developed by the community.

If the RP-200 is working as intended though the Hubitat device manager, then you might not have it set up properly in the Amazon Echo skill. It sounds like Alexa thinks the device is an on-off switch rather than a dimmer.

All my dimmers are Lutron Caseta devices. I do not have any Z-wave dimmers that I can test on your behalf.

I found the problem. As I mentioned, I changed the driver to smart dimmer, and nothing changed. I then dropped the device out of Alexa and re-added it after changing drivers. That seems to have worked! I guess just bouncing issues off someone else can jog me into making changes repeatedly, hitting the right combination. Thanks for helping to keep my plugging away still plugging.

Here's the weird thing: I've deleted all my old devices under Nexia, disconnected the Nexia Bridge, and closed my Nexia account. However, when I re-added the dimmer, it found TWO devices- the current Hubitat dimmer, AND the old non-existent Nexia version. It also keeps re-discovering my smart thermostat, also in its old life under Nexia.

1 Like

I have seen a similar issue like that before with Node-RED nodes that have an associated skill to make virtual devices for Alexa only. I think it is just a caching issue of skills on Amazon's servers and I don't think we can really do anything about it. It should go away over time.

I also like the fact that "Did you turn it off and on again" gets another win in it's tally book.

The weird thing is having to re-enroll the light for the driver change to work. It just seems to me the driver handling happens on the Hubitat end- and Alexa should simply issue the command. That means when the driver CAN handle the command, Alexa shouldn't report it cannot. However, that may be tied in to the caching you mentioned. Perhaps the re-adding the device took the cached info on the device behaviour out of the loop.

Well if you look at the device page in the Alexa app, there is so info sent when discovered and who knows if that is updated dynamically. For instance the "description" in Alexa is generally the driver in Hubitat.

Also anytime I have issues with an Alexa device, it is always a good idea to unshare from the skill in Hubitat, delete the device in Alexa (most people overlook this), then reshare from Hubitat and discover new devices with Alexa.

1 Like

Right- but that data field seems it should only be an identifier, not the driver handler itself. If the driver is changed at the Hubitat level, Alexa should still send the command to Hubitat.

I think that makes a lot of assumptions that we have no knowledge over. Almost none of the code in your setup is visible to us. The HE drivers are closed source, the HE Alexa integration is closed source, Alexa servers are closed source. All we are given access to is the logs on the HE side, and obviously the input and output.

I agree it SHOULD only be an identifier, but who knows if it actually is. Also who knows if it is an identifier, but once you change the driver, it doesn't update and now the identifier is broken? There are a lot of ways it could be broken, but it is all speculation.

True. But I'd almost put money on Alexa not doing the direct talking to the drivers. I would be VERY surprised if that was the case. I think it much more plausible that Alexa sends a command to Hubitat, and that command is then parsed for input to the driver.

Otherwise, Alexa would have to be capable of interfacing with a ton of drivers on quite a variety of systems- and I'd bet they didn't program the system to do that, even with the skills system.

I agree with you, but short of joining the HE team or having a staff member chime in or investigate this I doubt we will ever really know.

Just to clarify, the issue was with the driver? Generic Z-Wave Dimmer didn't work but Generic Z-Wave Smart Dimmer did?

That seems to be the case.