Alexa stopped working

Alexa stopped working for a few days. I tried disabling the skill and re enabling, but now it fails to link.

Is it just me? Any hints?

Here are a few infos:

Tried multiple times. A few hours later it seems to have fixed itself...

After years of Alexa and Hubitat working seamlessly together I’m suddenly getting the message from Alexa that whatever device I’m trying to control is not responding. That is from multiple Alexa devices in multiple rooms trying to control multiple different devices.

I went into the Alexa app and the “Respond immediately” toggle was turned on. I toggled it off and clicked the Done button. I then turned the toggle back on and clicked Done but that didn’t fix it.

Any idea why this happened and how to fix it? I see this happened to someone else back in February so it isn’t just me. I did install the Hubitat Beta app a few days ago, but it wasn’t until today that this became a problem (and BTW I haven’t touched the Alexa app in months).

I’m using a C8 with that I installed May 8th.

Assuming you’re referring to the Hubitat mobile app for your iPhone that you mentioned in another recent thread, I can’t think of any reason why that would be related.

Me neither, but I’m trying to mention anything that may have changed recently. So any idea why this happened, and more importantly, how to fix it? In browsing the forums this seems to occur to people from time to time and I didn’t see any causes or fixes.

My first guess with anything related to Alexa is something stops working, temporarily, on Amazon’s end. In general, that is.

It’s a 100% cloud-dependent service, and Amazon makes changes on their end from time to time.

I wouldn’t attempt to connect dots between one person’s reported Alexa issue in February that resolved on its own, and another person’s issue in May.

So if you need to troubleshoot your connection to Alexa, you might want to create a new thread with info specific to your problem now.

1 Like

Thank you. I’m at work and will, hopefully, see if it clears up on its own by the time I get home.

Hub possibly lost cloud connection or connection with Alexa, have you rebooted the hub?
Have you looked in the logs?

1 Like

I haven't looked at the logs, as frankly I'm not advanced enough to really tell what I'm reading. I didn't reboot the hub as everything else is working. A week or 2 ago everything stopped working (e.g. the "favorite/config" button on my Inovelli light switches did nothing and I couldn't turn or or control my Hue bulbs) so I rebooted the hub and everything started working again. If this persists overnight I'll try that.

If you filter the past logs to only the Alexa app and post a screenshot lots of people here can decipher the logs.

Thanks. Alexa appears to be suddenly working again. Ah, the mysteries of home automation.