Alexa skill controls device but says the device is not responding

Has this problem existed ever since you started using the Alexa Skill?

Yeah. Never had trouble with Hue either. The reason I didn't mention it. I believe there's a direct, non-cloud connection happening with the Hue since their discovery method is so different, requiring the button to be pressed for authorization sometimes.

However, I have had issues with Insteon and Wink. So I'm just taking guesses here based on experience. I can tell you for sure I have no problems today and have not had any for a few months. So I don't suspect an issue with the Hubitat Skill or cloud connection.

No. IT seemed like it worked fine when I first set up. I am not exactly sure when I started see it. Maybe after the firmware update that was immediately after the launch of the skill..... I thought it was intermittent so I didn't bother reporting it, but I just tried it again and it's still happening every time.

Have you changed your router in that time? Also, what about a modem reboot? I have an older ISP modem that needs a reboot every so often. Things will work, but not 100%. Some devices won't connect to the internet, etc.

No, I haven't and everything for my automation is using DHCP reservation

I can give that a try. I can't remember what I've done at this point.

Fixed my issue:


I'm still having this issue. At least some of the devices are generic z-wave dimmers so I don't think that's the issue.

I've also tried completely disabling the skill and all devices and re-enabling but it's still happening.

Hmm... whats weird is some of my alexas say the device is not responding and some respond with the ok...

I have the exact same problem. Sometimes says sorry DNR and sometimes it gives me the all clear.

After upgrading to Firmware 2.0, I'm still seeing this issue - Alexa controls devices, but claims 'device not responding'. @bobbyD, @bravenel - thoughts?

Obviously this is lower priority than the issues some of us are seeing with the new polling functionality causing false physical events (Question on Z-Wave Polling in 2.0), but it would be nice if there was an easy solution for this.


I don't think this has anything to do with HE. I get DNR on occasion when asking Alexa to control a Hue light, even though the action was carried out. This was happening long before I added HE into the mix.

Interesting data.

In my case, it is a near constant DNR (even though the action occurs) for certain lights. Switching things to generic Z-wave dimmer (per other suggestions) worked for a while, but during the 1.1.x series of firmware upgrades, it cropped back up again.

Note that this was working with HE in earlier combinations of firmware/Alexa skill/app, so something has definitely changed somewhere. :slight_smile:

My wife thinks it's hilarious when I yell back at Alexa "It just did you stupid twit"


We say similar things, but usually things that can't be repeated in polite company. :laughing:

This is my experience also. For some devices it is always (or almost always) giving this reply, but the action happens. I have just recently started converting most of my devices from Vera to HE, so I do not have a trail of experience with this issue that extends beyond one week. Most of my Z wave dimmers (Cooper Aspire) are "generic dimmers". However, I do have a couple of HS 100+ dimmers which have a different designation in the configuration. I will test them when I get home and report back.

So I did some looking into it. In my setup, I have z wave dimmers from Cooper and evolve(linear), on/ off from cooper and GE, and Hs ws100+ Z wave plus dimmers that have been installed so far.


  1. on/ off switches do not present any error from Alexa. ( Generic z wave on/off)

  2. Z wave dimmers, except as noted in (3) below, produce error message consistently. (Generic z wave dimmer)

  3. The Homeseer HS WS100+ Z wave plus dimmer report without problems. They are configured as Generic Z Wave CentralScene Dimmers.

I hope this helps someone more capable than I resolve whatever causes this bug


This is consistent with my experience as well - Generic Z-wave dimmer seems to be the main culprit in this case in my setup.

I am having the same issue. I finally started converting devices over from ST last weekend. On some of those devices I converted I am often (90% of the time) getting "Sorry xxxx is not responding" on devices with "Generic Z-Wave Dimmer" as the device type. I do get the "OK" reply often enough to know that it does sometimes work correctly. When I get the error message the action also does not show up in the event log for the device. If I click "refresh" the current state will update to show the correct information. When I specify a percentage it seems to work fine every time, it is just on and off that fail. Most of my devices are older devices. I can’t afford to replace all of them just to work with HE. Alexa is my main control point for Home Automation, (or Home Control if you prefer)

Device info for 1 of the problem devices:

  • deviceType: 8200
  • inClusters: 0x26,0x27,0x75,0x72,0x86
  • deviceId: 2051
  • manufacturer: 265

From the system Log with debugging turned on:

There are some discrepancies even when just toggling between on and off using the web interface:

I've had this issue too, and have mostly observed it with my generic smart dimmers as well. "Alexa, turn dining room off..." spins for a second, light turns off, continues spinning for another ~10-15 seconds, "device did not respond, etc."

Thanks Keo! I have a Leviton Decora Smart dimmer (DZ6HD) and was having the same problem where Alexa would properly turn on/off/dim my lights, but report "Sorry is not responding)" about 10 secs after performing the command. I changed the HE device type to Generic Z-Wave Dimmer, deleted device in Alexa->Smart Home, then clicked Add Device to let Alexa rediscover the dimmer again and now it works properly. Alexa now says "OK" about 1 to 2 secs after performing the requested command...


I too am having this issue, primarily with devices configured as 'Generic Z-Wave Dimmer'. Other devices appear to work more consistently. I've tried removing all of the HE devices from the Alexa app, removing the Hubitat skill on Alexa, removing the Amazon Echo Skill app from HE, then starting over. Nothing helps.