Alexa not responding

My symptoms are not a complete match. The router was out this morning so I rebooted it. Partial success so I restarted HE. More or less working, but slowly. I occurred to me to restart my computer and then things were running at usual speed. Unfortunately Alexa says that a light switch request (which always works) is not responding. I am able to control the switch through the HE dashboard. Not sure what else I should try to get Alexa back.

Amazon is slow to remove the offline messages once a device comes back online. Eventually Alexa will clear the flag.

1 Like

OK. I'll wait although it's been 3 hours so far.

Is your hub connected to the cloud? Do you have a message in the upper right corner saying that cloud is not available? Three hours seems excessive, it should have been corrected by now, if your hub was online.

At least Alexa is no longer saying that the light switches are not responding, but she says 'Yes' and nothing happens. I'll keep waiting.

Hi Bobby,

Missed your message about cloud connection. I'm looking for the cloud notice and can't see it. Is there another way to determine if I don't have a cloud connection? I looked in hub settings and didn't see anything obvious.

I finally found the cloud notice. It says cloud connection is unavailable. How do I fix it?

Simply rebooting the hub from Settings may resolve the problem.

1 Like

I had tried rebooting earlier. I just did it again and got same system message:

Cloud connection is unavailable.

One other thing that could prevent your hub from connecting to the cloud is if the hub's time drifted off. To correct the internal clock, go to Settings, then Hub Details and select update time from browser.

Other than that, something else on your local network might be preventing the hub to access the internet. Basic network troubleshooting like rebooting the router, ensuring that firewall policies aren't blocking the hub might help.

1 Like

I corrected the internal clock. Since my Netgear router administrator app shows an IP assignment for HE, is that equivalent to HE having internet access? I also checked my G Data security app and it says that no applications are being excluded. I've also rebooted my internet modem, my router and HE a couple of times. Still no luck. I'm reluctant to reinstall Alexa but will if I need to.

Nope. That just means your hub has been assigned an address that permits it to access your LAN. It doesn't mean that it has permission to access the internet.

What is this? On what does it run? Have you tried disabling it?

1 Like

How do I determine what permissions HE has vis a vis the internet? Also since Alexa has been running for some months and only stopped working this morning after the router needed rebooting, that might give a clue as to where to look.

G Data is an anti virus/ anti malware suite. It runs on my computer. To my knowledge it has never caused a problem during the years I've used it.

As long as it isn't doing something like ARP spoofing to block devices on your LAN from accessing the internet.

I could ask the G Data folks if their software does something like that but would be way surprised if it did.

I'm replying to this thread since the original problem (cloud not available) finally resolved itself, albeit at a very leisurely pace. Per advice, I rebooted the hub a couple of times though nothing happened immediately.

I have the same problem again after I had to turn off the power to the hub to do some electrical work. The router came back as did the hub but the cloud is not available. If this is going to be a recurring problem, what should I do when I know I have to shut off the power? Should I shut the hub down in advance rather than let the hub just stop when the power goes off?

I can't answer the other part of your question, but you should never just yank the power to any computer, Hubitat included. There have been some people who had corrupted databases on the Hubitat when they did a rude shutdown like you have been doing. It is recoverable via a soft reset, but if you don't have to do a soft reset in the first place by just shutting down properly, it is probably the best thing to do.


Understood. When I plan to turn off the power I'll shut the hub down, just as I power my computer down.
Of course there are times when the power fails. Despite what you may have heard, California is infamous for an unstable grid.

I do know not to do a hard shutdown, despite having seen SAs pull the plug on a unix server.

Hence the recommendation to put your hub on a UPS. It is also possible to monitor some UPS' using Hubitat. I use an automation to shut my hubitats down when they've been on a UPS for longer than 2 hours.