Alexa Not Finding Your Devices?

Also try removing (forgetting) all devices from the Alexa app itself.

Well Todd, I know that it must be a frustrating experience. Hope you’re not getting fed up with everyone telling you to try this, and try that…:smiley:

I’m not convinced about the multiple Hue theory @oldernstone. I have a Hue bridge connected to AVS and don’t have this issue.

What I would suggest next, if you’ve exhausted all other router tests, is resetting your Echo (push the little pin hole on the bottom). I know, that sounds bad, but it’s not as horrible as one might think. I actually did it a few days ago and although I had to fix groups, routines and bluetooth paring, it wasn’t as bad as I imagined.

I’m not just grasping at straws here. All these suggestions are based on experiences I have with just these types of issues. I have 7 different hub/bridge types in my house and 5 of them have had issues with device discovery in the past. It’s not always an easy task with Echo.

If all else fails, immolate and defenestrate. :smiley:

1 Like

I know in my setup I don't have 2 routers. There is 1 modem and 1 router (The airport extreme), so there is no Double NAT. I believe I read in another post that @todds89 has a similar if not identical setup as mine. So I am confident this is not a double NAT issue.

Ok, so if that’s the case, the issue may be on the Amazon side. A reset of the Echo may help if that has not been tried.

This has to be something with how Hubitat is being discovered. I used this:
https://community.hubitat.com/t/release-other-hub-smartthings-integration-2-0/672
To replicate my devices on smartThings and then setup the smartThings skill. Alexa found all of the devices that were replicated over to SmartThings.

I also installed a brand new switch that has never been used and joined it with hubitat. I also added a test virtual switch and attempted to have them discovered by alexa. Nope! Didn’t work.

Perhaps, but the SmartThings skill is the difference that is significant. Since Hubitat is emulating a Hue bridge as far as the Echo is concerned, it may not be a problem with Hubitat.

I have not disabled my SmartThings skill, I have a Hue and I’m not having trouble with discovery. Have you tried a reset of your Echo (the pinhole on the bottom) ?

Yes I have.

It still seems like the common denominator is the Apple Airport Extreme router.

I know no one likes changing out a router… but it seems like the next logical troubleshooting step based on the information that we know at this point.

I would try an Asus, Netgear, Linksys, TPLink, etc… to see if it makes any difference. I personally use an Asus RT-AC86U running AsusWRT-Merlin firmware.

1 Like

I have an old Time Capsule. I’ll set it up again tonight to see if I can duplicate the issue.

1 Like

Some people with Airport Extreme Routers have no problem, and some do. I wonder what it is about the settings in the router that might be the reason. I purchased an Airport Extreme last summer, and ran Hubitat and Echo on it with no problems at all. That system is still running. I’m currently running Echo from a new Time Capsule wifi network and have no issues with it. Those are very similar routers.

1 Like

Wonder if older firmware versions are a factor? Mine is the original Time capsule and regular firmware updates stopped at a certain point with that one. I’ll test late tonight.

I’m not able to duplicate the problem using a version 1 Time Capsule with firmware 7.6.9
I set it up with DHCP and NAT to make sure I had a double NAT as this was previously suspected. I also selected the default Apple IP range of 10.0.1.x

It just works. No problem. As long as the Echo is on the same network as Hubitat, it works fine. However, I did forget to add the virtual switches to the Hubitat Amazon Echo app at first, that definatley stops discovery, but once I remembered to select them in the app, it worked fine.

On a side note: @bravenel Perhaps the team could discuss renaming the Hubitat Amazon Echo app. It’s easy to confuse it with the Amazon Alexa app in discussions. Maybe “Hubitat Alexa app” ?

We have something in development that will replace that app. And provide more capabilities.

1 Like

Mine is setup the same and running 7.7.9, Echo is on the same network … doesn’t work for me, and at least one other @jprosiak

That's not a cheap troubleshooting step. If this is a problem with how the router discovers the bridge, what protocol is being used? Maybe there is a configuration change I can try within the router settings.

I've had problems with router failing after a 1 - 3 years until I bought my Airport extreme, so I am not willing to spend more money just to get voice commands to work.

Are you running the same Airport Extreme firmware version as @todds89 ?

Yes I am. 7.7.9

I just wanted to check.. which specific Alexa device is not working inc any V1 V2 designations. An Alexa Show Is known to not work and V2 Dots can be problematic. I believe however you’re using an original version Echo.

Some other people trying to discover devices that emulate a Hue hub are experiencing problems with the timing of the UPnP responses causing them not to be recognised. Other emulators have fixed this for a lot of people by adding slight delays between responses.

In the issues section of the ha-bridge repository on GitHub are a lot of topics like this one .. worth a peruse. Some issues with switching members within a household too.


The timing issue I mentioned is in this thead.

Oh, I had a thought. Do you have a packet priority system running? Can be called QOS. If it’s on, try turning it off. Maybe the packet priority is causing an issue?