Alexa not finding new Hue lights and scenes

I have 2 hue hubs in my house so I need to use Hubtat so that Alexa can work with everything. It has been perfect up until now, however I just added a series of exterior lights to my house and they have been found and set up perfectly in coco hue, however when I used the Alexa skill and added them when I discovered devices they are not showing up at all on my alexa. This is also true for a couple of new scenes in existing rooms.

It has been a while since I did this last, am I missing something here? I am very confused right now.

Out of curiosity... Is the “Exclude Hubitat Integrated Hue Devices.” toggle on or off? Not sure if it makes a difference for coco hue or not, but it might...

No it is not on.

Darn. Have you checked your logs to see if there are related errors?

No errors I can see, maybe I am not looking in the right place?

Here is where you can go to the log, and what errors look like. Clicking on the device number on the left will show all the logs only for that device. Clicking on the word “Error” or “Info”, etc. will bring up the offending device or app.

@bertabcd1234 has quite a bit of experience with coco hue where I have never used it, so tagging him in case he can be better than me at helping figure out what this could be about...

I've never used CoCoHue devices on Alexa, but I think others have without problem. The only related issues I remember hearing about is with Google Home, where it doesn't like to add bulb (and probably similar) devices unless all attributes ("Current States" on the device page) are populated, whcih should happen on the first poll. However, for some devices like groups, which may claim to implement more capabilities than the member bulbs, this sometimes didn't happen, so sending enough commands to fill out thr set of attributes (the driver assumes they worked if the Bridge says they did, which it will even if they don't support this) like "Set Color" and "Set Color Temperature" worked. If these are scenes, I'm not sure since they're pretty simple drivers, but try "On" or "Off" if you don't see "switch" under "Current States."

Otherwise, I could try testing this if you let me know what drivers the devices are. I should also note that one reason I don't do it this way is because the Hue Bridge has native support for Alexa and I don't find value in putting Hubitat in between, but perhaps you have a reason or preference here (unless it's a v1 Bridge where this is indeed now the only way!).

1 Like

Yeah, it worked fine before. As I have a bunch of CocoHue lights working just fine from months ago, it is just this new series that is not working. The issue is for my house I NEED to use CocoHue as I have too many bulbs for one hub. I need 2 hubs just to get them all running, and all. A few of them have now showed up on my Google Home stuff, so I can now use that, but yeah still a bit confused.

Ah, yes, that would be another reason. I wish I was able to help more here, but I'm not able to replicate the problem. Do you see any errors in the log when hitting "Done" in the Alexa skill? Does the "Current States" area on the device page for the ones that don't work look similar to ones that do? I can't figure out what might be making this happen (unless there's another reason like a maximum number of devices per other things add OK?).

I just added quite a few new Hue lights to Alexa via CoCoHue without issue. I would think it must be something odd with your Alexa account or integration.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.