Alexa - group not responding

I'm new to Hubitat but have gotten a bunch of Zigbee lights connected and working with the system. Through the portal I can reliably control the lights without a problem. I added the Alexa skill and about 50% of the time it works fine when controlling my lights as a group. The other 50% of the time, when I ask Alexa to do something with the group of lights, the blue lights spin for a prolonged period and then I get the response "Sorry, the group living room is not responding." Unlike other posts I've seen here, the lights DO NOT respond. So basically it just doesn't work.

If after Alexa stops working I open the portal, I can control the lights just fine. Once I use the portal to change something with the lights, Alexa starts working again to control the group.

Would love to hear any ideas about what's going on. I've tried to update the Hubitat to the latest software, but then my hub won't respond, so I hd to roll back to the previous version ( as directed by Hubitat support since they haven't been able to figure out why the new version is not functioning on some hubs. It's brand new and the settings say it's Rev C-7.


You'll have better results if you create Hubitat Groups. These are local groups on the hub that will create a virtual device associated with controlling the group, instead of Alexa Groups that are cloud based trying to reach out to each light via the cloud.

Share the group device created with Alexa and use that for control. I don't even use Alexa groups for that same reason you're describing. It's not just Hubitat that they don't work well with.

I don't think that's the issue here unfortunately. I just did another test. The group was not responding, so instead I tried to turn off just one light, and got the same result, that the light was not responding. It was all controllable via the Hubitat dashboard I created, but not via Alexa. And in fact Alexa is still saying the devices aren't responding, either the group or the individual lights. Very frustrating. Hoping someobe has some idea about what the deal is here.

You're guessing if you haven't tried it using the Groups and Scenes app. It has Zigbee group messaging available. You cannot do that with an Alexa group.

1 Like

Hmm. You may have found the answer. I deleted the group in Alexa, then added my hubitat group of the same lights and things are now working. I'll give it a few hours and try again and see if it's more consistent. Maybe it was getting confused by the Alexa groups. Fingers crossed, Thanks for your help!

1 Like

Knew :stuck_out_tongue_winking_eye:

Arrgh, Well, unfortunately I just tried again and Alexa has lost the connection and is saying that the Hubitat group is not available, nor are any of the individual lights. Let me know if anyone out there has any other ideas.

Did you share the virtual device that the Hubitat groups and scenes app creates? That is what you treat as a group. You don’t put it into an Alexa group. I’m standing in my kitchen and just turned on my overhead lights by voice, which are a Hubitat group, enabled from Alexa via the group device and it works perfectly.

As you can see, I don’t use the Alexa Group feature at all. Groups are handled by HE, with the exception of my Hue bulb groups, which are handled by the Hue bridge because they have their own Zigbee Group Messaging.

1 Like

Yep, added the "Living Room Lights" as a light (that's the Hubitat Group). It worked at first. Seemed OK for awhile, Now it's giving me the "device not found" message and is showing all of the individual lights as offline. I can stop sharing the individual lights from hubitat. Maybe that's causing a conflict? Although it would be nice to be able to control the individual lights as well as the group. Tried to upload a screen shot but the forum won't let me because I'm a new user.

Yeah you have to pass some milestones before you can post images. It’s an anti-spamming feature of Discourse.

Naming will screw up Alexa. Keep them distinctly different and if you don’t need to control the bulbs and dimmers individually via Alexa that are also included in groups, it is best not to share them with Alexa.

If you continue to have “not responding” issues with other devices (not just groups), then you might try removing the skill from the Alexa app and adding it back again. No need to uninstall the Amazon Echo Skill app on your hub though.

Thanks,. I removed everything except the group from what was being shared with Alexa and it still works for a little while then becomes unreachable. I have also removed and re-added the skill (twice). It works for about 15 minutes then loses connection again. It's a bummer, but not sure the hubitat is going to be the device for me. I guess I'll wait and see if they can get the software upgrade to work on my unit soon (no additional responses from tech support since they told me to roll back to the older version). Otherwise, I think it will have to go back and I'll look for another option. Currently I have a lovely $140 paperweight. :slight_smile:

You don't have a paperweight because Alexa cloud is not working right now.

Can you confirm that if you operate from the device details page for the Hubitat group device that it operates each time without fail? If it doesn't then you may have a weak Zigbee mesh, or you need to make adjustments in the Group settings in HE. Not all devices are going to work right with on/off optimization enabled like I have. Also Zigbee group messaging doesn't always work right across device manufactures, so if the devices in that group are not all Sengled, then try disabling the Zigbee group messaging option too.

If the bulbs do all reliably operate each time when you turn the device on and off from the device details page (not the dashboard, don't use dashboard for testing), then it's an Alexa cloud issue. Hubitat is about automating your home, so the real value is in setting up automations in my opinion. Alexa is just a voice remote control that doesn't always work right, because cloud based devices don't always work. That's why we're here with a device that doesn't need the cloud to perform its primary functions.

It works fine from both the dashboard and the detail page. Just not from Alexa. I have been using my Alexa with a Wink Hub for years and it's always worked flawlessly. Honestly it's very hard for me to think there's some kind of cloud issue with Amazon to explain this. Everything else the Echo can do is working fine, just not connecting with the hubitat. The paperweight comment was a bit too much, but after deleting and reinstalling in myriad ways and having the same loss of connectivity every time, I'm feeling a bit irritated by it all. I guess it comes down to a decision of whether I want to keep a hub that doesn't seem to want to play well with my echo or try another type of hub, Hopefully tech support will get back to me and let me know if there's any other troubleshooting I can do to solve this. Thanks for your input. It's appreciated.

Nothing has changed on the Alexa integration for quite some time. I'm not running the latest on my main hub. I'm using the previous release still. You mentioned you needed to roll back (there was an issue for some people updating. That's been resolved and hopefully won't reoccur in future builds), so if you're running then you and I are running the exact same version. I cannot remember when I had a problem with Alexa and Hubitat last. Every so often you'll get this "Sorry, the device so and so isn't responding" but it does it anyway. I get the from other Alexa enabled devices too, not just Hubitat, so in my books, that's an Amazon problem.

You might try deleting all your devices and rediscovering. That can be a pain if you have a lot of Alexa Routines, but it's a fix I've used for various Alexa issues in the past.

Yep, running It's still telling me that there's a new version available, but that's the one that caused my hub to not work at all. I have already deleted and re-added all of the bulbs. It seems like there is is not likely to be a solution to this problem and maybe it truly is something weird with my setup. I've contacted tech support about this, bit no response at this point. I was hoping that there might be some way to get debugging information. I guess I'll just have to decide how important connection to the Echo is to me and then choose either to keep this without Alexa support or return it and switch to a different brand. Kind of a bummer, It's a bit of a pain to set up compared to my old Wink but aside from the Alexa integration, seems to work well with my devices. Thanks for your help.

1 Like

Just a thought. Do you still have the Wink Skill active with the same devices? I would remove this Wink Skill if that’s the case. That could conflict and cause Alexa to say the device is not responding be cause it’s try to activate a device on Wink that is now on HE.

No, the wink skill has been deleted. I've tried a bunch of things this weekend. The new version of the update came out so I upgraded and the exact same problem is happening. I remove the Alexa skill, I reinstall the Alexa skill. It works for 10 minutes or so and then the dreaded Alexa device not responding message. I am finding that I can't access the cloud dashboard either. It's very weird. It works for 10 minutes or so, then stops working. I can't quite understand why it would work for awhile and then stop. I disabled all firewall and security measures on my WiFi router (a Plume), but nothing seems to change the behavior. I'll see if tech support gets back to me tomorrow.

Oh man. That would have been really helpful information from the beginning.

Updating the hub isn’t going to change this, because nothing has changed with the Amazon Echo Skill app. There’s nothing wrong with the Hubitat cloud connection to Amazon. Mine and many others here are using it every day without any disconnecting. Sure, there is the occasional issue where it says a device isn’t responding, but then controls it anyway, but that kind of glitch with the cloud is not a problem with the hub.

This is very likely a problem with the WiFi mesh. Guessing your Hubitat hub is plugged into the ISP router, and Echo is bouncing between the Plume access points. Can you go into an app for the Plume and restrict the Echo to just one access point? I’m able to do this with my WiFi mesh router.

Don’t know if it will help, but it might actually be better to plug the Hub into one of the Plume access points too.

Please don’t take offense, but Plume is possibly the worst mesh WiFi system there is. Reviewers all point to their inconsistent connections. Just went through this with a friend who swore up and down there was nothing wrong with the Plume mesh access points that Bell Canada put in their house (Bell bought these in large quantities because they were cheap no doubt). Changed out their Mesh WiFi system for a Linksys Velop and all the connection issues disappeared.

I only have one Plume access point so it shouldn't be bouncing around. And again, I also can't get to the cloud dashboard, from my computer after the initial 15-45 minutes, so I think this is an issue with external access to the hub. I have set the hub to have a reserved IP address that doesn't change. I have tried with the hub plugged into the ISP router and into the Plume and the behavior is exactly the same. I'll bring home a router from work tomorrow and try it on a standard wireless router to see if that fixes it. I didn't buy the plume, my fiber ISP installed it, so no offense taken. :slight_smile: Still confused about why the Wink and Echo worked fine for months with this setup and the hubitat is having so much trouble, but if the solution is just to use a different router/wireless access point, I'll be happy with that.