Airgapped home installation

I don't have internet in my new location and don't yet have a plan for getting it installed.
Part of the draw of this platform was the must work locally & without internet.

The getting started guide doesn't have instructions for connecting to & controlling it over a local internet connection. This seems like a major gap in the working locally without internet. Is there a way to configure & control this product without an internet connection?

The Hub arrives "empty" and with Registration, downloads the latest firmware... over the Ethernet connection across the Internet to the Hubitat servers.

Can you Enable a hotspot on your Phone?

Hi csteele,
I connected to the device at a friends house and have updated to the latest firmware.

I can enable hotspot on my phone.
If I do, how would that help me connect to the device?

Do you have something giving the device an IP address? You have to have at least a router or something giving an IP address to the hub. it doesn’t have the ability to assign a static address

You need to setup the Hub by joining ZWave devices, pairing Zigbee devices, etc. You'll want to create automations and have your devices do the things they were purchased to do. :slight_smile:

Many of those steps will cause you to want to get a Community created device Driver or App. You'll need the Internet for that.

I'm not clear on your network, except for the part about you not having an ISP. But the Hubitat hub comes with an Ethernet connection that you wire to your home network. Perhaps you have a Wireless Access Point (WiFi) and you can use your phone to be an Internet access point. You'll use a browser to configure the Hub, and the same browser, will (usually) visit github to get driver / app code. You then paste that into the Hub's UI.

I have a switch that I can connect between my device and laptop, but thathe didn't seem happy... it didn't really detect and the portal showed as if it was still at my friends house.

I see the other post that says I can't set it up with a static ip... seems kind of silly. I can keep a lookout for a spare router.

You’re not concerned about security because you’re not connected to the internet so as long as there’s decenct WPA2 WiFi Security (assuming you are going to use WiFi with your computer), then any cheap router will do.

After installing the firmware update and seeing the hubitat come up at my friends house in a normal configuration, I went back home, found a spare router and tried the suggested topology.

so the laptop and hubitat are both plugged into the router via cable. The laptop is connected to a mobile hotspot. the hubitat is not detected with or without bridging the lan and wifi connections.

I acquired a router like suggested so that the hubitat could use the dhcp server.

When I log into the routers admin page, I don't see the hubitat listed as a connected device. I see the link indication on the router though, so I'm sure the wire is good. Is my device somehow bricked?

Maybe I'll take it back over to my friends house this weekend. Currently my main zigby IOT devices are recessed lights & a smart lightswitch that I can't take with me, but I plan to pick up a smart outlet that I can play with over-there.

IS DHCP turned on in the router? Make sure both devices are plugged into lan ports, you cannot use a lan port for one and wan port for the other.

The easy answer is, what is the IP of your computer? If you can swap the cables with the hub and your computer still gets an IP address, then that’s your answer as to whether the cable is bad or not.

Also, as @drew suggested, make certain they are both connected to the LAN ports. There's a whole lot more it could be with a router, so start with the baseline. Without changing anything (unless one of the cables is plugged into the WAN port), just check you have an IP address on your computer. If you do, take the end of the cable out of your computer and put it in the hub. Take the end of the hub cable and put it in your computer. Do you still get an IP address after a minute?

If your friend lent you a mesh router, that won't work. They often need internet to give you an IP address. Also, if it was factory reset before he gave it to you, some of them go into a setup wizard and don't assign an IP until you either set it up via the wizard or manually set it up. Further, some will even get stuck looking for an internet connection until you manually configure them.

That implies DHCP is not enabled / functional.

You were successful at your friends house and now your Hubitat "account" is tied to their IP, I suspect. You take it there and you may be successful. Support can assist with moving it. But the DHCP address given the Hub at your friend's house won't be the same as your DHCP. And that has to be resolved first I imagine. Your new router had to have been configured for a static assignment of a dhcp address from the Mac address of the hub. You should then be able to browse to the IP address you allocated.

http://{the IP you assigned in DHCP}/
http://{the IP you assigned in DHCP}:8081

that 2nd is the URL to revert a firmware... you don't have one, BUT you should see the "empty" page, telling you what version you are running.

@drew and @SmartHomePrimer are giving good guidance. We are all "seeing" the same thing. --> the local lan IP of your hub isn't being set. <-- and you saw that immediately too. That's where you need to focus, with help from Support.

This morning I switched the cables and then the hub it at was visible from the routers admin page. Not sure if unplugging and plugging in made the hubitat re-initiate the dhcp or if it''s lease on the previous up address expired...

Anyways the portal wbe site didn't really work in this configuration. I needed to directly access the hubitat by ip address. The hubitat still has the firmware downloaded at my friends house.

Thanks for all the help!

1 Like

Yes, won't work without a DNS server. You'll need to always find the hub at a specific IP. You should reserve an IP address in the router based on the Hub's Mac address which can be found in the Hub Details. If you don't, every time the lease expires, you may get a new IP (read, you probable will).

Yes, that's what I was trying to point out. The DB within Hubitat's corporate server is expecting to see your Hub on your friend's internet address. You have to allow your hub time to "converse" with Hubitat corp and identify your new address. OR contact support and they can speed up that process.

You will normally browse to your hub's LAN (dhcp) assigned address to perform any/all administrative tasks. Adding devices, creating automation, creating dashboards, periodic upgrades, etc. All the tasks that modify the Hubitat Hub will be done by browsing to your hub's IP address... not the portal. The portal can be used, but in your air gapped circumstance, it would rarely work, so browse directly to the (fixed address) of your Hub.

Air gapping implies you'll never want this BUT... when you're away from home and you want to check on your home, you can browse to your Dashboard via the portal. Remote access is intentionally limited to USING the Hub, not configuring it.

If it's not already implemented, it might be good for situations such as this if the hub would default to a known or predictable IP address if no DHCP server responds. That way, if there is nothing else on the network except a workstation, the user could re-IP the workstation and be able to access the hub.