Aircoookie WLED integration to HE

Thanks for your work on this code. I was able to get the integration working on one WLED on a D1Mini. It works well and I have it in a rule that works well.

Now, when I try to add a second one, it doesn't work. When I try to turn the light off or on, it doesn't work. The error in the logs is
something went wrong: org.apache.http.client.ClientProtocolException

I have tried it on other D1Mini's and NodeMCUs.

Any ideas?

Oh man. I figured it out. I left off the http:// before the IP address! Dumb mistake! I'm so glad it works now tho.

How is this thing playing out?

Ive ordered my wleds and I'm eager to have a play for Xmas!


1 Like

Is there an easy way to select the effect? Seems a bit of trial and error. Great stuff though!

I'm mostly using the MQTT driver but I have this one installed on one WLED instance.

This one is far easier to set up, no need for an MQTT server. Just remember to put http:// in front of your ip address. It responds instantly. Picking effects is a bit cumbersome as it expects numbers to be entered.

1 Like

Thanks. I'll try sticking with aircookie/wled if possible. I'm just trying to get my head around this before I start snipping =p

Forgive the pics, very little free time !

Current setup works for whole strip. I.e

If I half the strip, will these two setups work as (badly!) Illustrated ?

Single segment.

1 segment, split into 2 identical strips



Both setups will work as you understand, as long as you keep the direction of the data line as indicated on the strips by the arrows.

PS should also connect power and GND :crazy_face: for them to work.

1 Like



hi all. can't figure out how to change the intensity / speed via webcore commands. Is this possible?


This is all I can see. So at the minute I think I need to set some options through wled itself, then as long as nothing changes, I can control the simple stuff from webcore.

Was hoping there might be a way of controlling more from webcore without needing to log onto the web interface / or click on device options... to automate as much as poss.

Am I not quite grasping something? Any help much appreciated =)

This might be foolish, but is there a way to deconflict this and Prismatik? I'm using WLED and Prismatik for reactive bias lights, and have this set up as well, but I think as long as Prismatik is running commands from this will effectively be overridden. The real goal is just to be able to have real on/off control either from a button or by voice.

Sorry, don't use WebCORE so couldn't really help with this one. The setEffect command takes multilple arguments which include speed and intensity. It's a custom command though, so it might not be supported by WebCORE?

Whatever is issuing the latest command to WLED will initiate the change. The MQTT driver by muxa would give you more real-time updates on the device.

1 Like

Thanks for the reply. I'm not really sure what the crack is with webcore/custom commands. =/

Hey Blink,

This has been working great for me since you added the ability to control brightness per segment and I've added a handful more devices around the house now that I can dive up the segments properly.
More of a question than a request: is it possible to have control of both the master brightness and the segment brightness in the same driver? I've actually kept both versions of the driver so that I can use which ever version will work better for the given application, but even with that, I still keep encountering scenarios where a preset that changes the master brightness messes up changing the segment brightness and I can't get around it without pulling out my phone to fix it with the wled app.
I've been looking over the code to see if I can implement this myself but with my limited understanding of the commands used, I get the impression that hubitat drivers only allow for a single brightness dimmer, so I can't just add another button for master or segment brightness.
The other thought I had was to nest each segment as a child device with per segment controls into a master device that can change everything at once when appropriate. Would that even be possible?
I'm trying to piece together how that would work by comparing the code for your two driver versions and that for a couple different double outlets I have. I'm not even sure if that'll be possible to do, so I might end up wasting months of my life for no reason, lol.

And thanks again for the changes you implemented in the spring.

Does anyone know if this driver is compatible with WLED version 0.11.0? I just got up and running yesterday and flashed 0.11.0 to a Dig Uno ESP8266 controller. When I installed this driver and entered the IP address (doubled checked it was correct and included the http:// prefix), I get a number of state variables populated but clicking "on" and "off" does not change my light strip. I got things working in Home Assistant but can't seem to get them working here in Hubitat. Trying to figure out if 0.11.0 might not be compatible before I do more troubleshooting.

I have been using the driver with a new build using version 0.11.0 for a week or two now (I can't remember exactly when I finish putting it together) and it works just the same as with previous versions.
Having said that, I installed the driver sometime in the spring and I'm not aware if any changes have been made since then.
Maybe double check that you have your segment enumerated as 0, assuming you just have one segment. That was a mistake I made the first time I used it, putting 1 instead.

1 Like

Hi @justinrsteele and @blink

I am having the same issue, I have loaded WLED 0.11.1 and I can get all the info about WLED but if I turn off via the device page about 2 seconds later it automatically turns on again. If the strip is on via the WLED app and I try turn it off from HE, it does not do anything? I have the URL correct, I have segment set to 0 and update rate is 30 seconds??

Can anybody help?

I would like to be able to cycle through random colors and effects with the press of a remote button in each of my kids rooms. Any chance this driver will allow me to do this?

Were you able to get this working? Iā€™m also having trouble getting WLED to turn off, also running 0.11.1. Thanks.

Hi @TroyP @blink

No I was not able to get this to work, so I have disabled the rule currently. Was hoping someone would come up with the solution.